1108 Finding Average (20 分) 字符串處理 sscanf和sprintf 格式化

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input 2:

2
aaa -9999

Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

題意:把合法的數字加起來算平均值,合法:[-1000,1000]的最多兩位小數的數。

 

發現了一個神奇的東西!sscanf和sprintf 格式化!省去了很多判斷!

sscanf與scanf等價,所不同的是,前者的輸入字符來源於字符串s,而scanf以stdin作爲輸入源。

sscanf("123456 ", "%4s", buf);  取指定長度的字符串

取到指定字符爲止的字符串。如在下例中,取遇到空格爲止字符串。
  sscanf("123456 abcdedf", "%[^ ]", buf);
  printf("%s\n", buf);
  結果爲:123456 

sprintf(s, "%d", 123); //產生"123"

更多用法:https://www.cnblogs.com/wangtianxj/archive/2009/07/04/1516646.html

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
using namespace std;
int main()
{
	int n,i,j,l,sum=0;//sum 合法數 
	double s=0,temp;
	char a[105],b[105];
	scanf("%d",&n);
	for(i=0;i<n;i++)
	{
		int f=0;
		scanf("%s",a);
		sscanf(a,"%lf",&temp);
		sprintf(b,"%.2f",temp);
		//cout<<a<<" "<<b<<" "<<temp<<endl;
		for(int j=0;j<strlen(a);j++)
		{
		     if(a[j]!=b[j]) f=1;
		}
		if(f||temp<-1000|| temp>1000)
		{
		    printf("ERROR: %s is not a legal number\n",a);
		    continue;
		}
		else
		{
		    s+=temp;
		    sum++;
		}
	}
	if(sum==0)
	printf("The average of 0 numbers is Undefined\n");
	else if(sum==1)
	printf("The average of 1 number is %.2lf\n",s/sum);
	else
	printf("The average of %d numbers is %.2lf\n",sum,s/sum);
} 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章