1102 Invert a Binary Tree (25 分) 翻轉二叉樹並輸出層次遍歷和中序遍歷

1102 Invert a Binary Tree (25 分)

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

 

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<string>
#include<sstream>
#include<algorithm>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<vector>
using namespace std;
#define inf 0x3f3f3f3f
#define LL long long
vector<int> vd;
int l[20],r[20];
void dfs(int u)
{
	if(r[u]!=-1)dfs(r[u]);
	vd.push_back(u);
	if(l[u]!=-1)dfs(l[u]);
}
int main()
{
	int n,i,j;
	char x,y;
	map<int,int> ma;
	scanf("%d",&n);
	for(i=0;i<n;i++)
	{
		getchar();
		scanf("%c %c",&x,&y);
		if(x=='-')
		l[i]=-1;
		else
		l[i]=x-'0',ma[x-'0']++;
		if(y=='-')
		r[i]=-1;
		else
		r[i]=y-'0',ma[y-'0']++;
	}
	int root;
	for(i=0;i<n;i++)
	{
		if(ma[i]==0)
		root=i;
	}
	queue<int> q;
	vector<int> v;
	q.push(root);
	while(!q.empty())
	{
		int u=q.front();
		v.push_back(u);
		q.pop();
		if(r[u]!=-1)
		q.push(r[u]);
		if(l[u]!=-1)
		q.push(l[u]);
	}
	dfs(root);
	for(i=0;i<v.size()-1;i++)
	printf("%d ",v[i]);
	printf("%d\n",v[v.size()-1]);
	for(i=0;i<vd.size()-1;i++)
	printf("%d ",vd[i]);
	printf("%d\n",vd[vd.size()-1]);
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章