1127 ZigZagging on a Tree (30 分) 後序和中序遍歷建樹後輸出Z字形層次遍歷

1127 ZigZagging on a Tree (30 分)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

zigzag.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

題意:後序和中序遍歷建樹後輸出Z字形層次遍歷 

思路:建樹把結點的左右兒子存在l和r數組中,因爲要z字形層次遍歷輸出,所以我先把深搜跑了一遍深度,知道每個結點在第幾層,然後正常的用queue跑層次遍歷,把每個結點層在他相應的深度的vector裏,然後根據深度的奇偶跑Z字形。

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<string>
#include<sstream>
#include<algorithm>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<vector>
using namespace std;
#define inf 0x3f3f3f3f
#define LL long long
int post[1005],in[1005];
int l[1005],r[1005];
int dfs(int postl,int postr,int inl,int inr)
{
	if(postl>postr) return -1;
	int root=post[postr];
	int pos=inl;
	while(in[pos]!=root) pos++;
	int cnt=pos-inl;
	l[root]=dfs(postl,postl+cnt-1,inl,pos-1);
	r[root]=dfs(postl+cnt,postr-1,pos+1,inr);
	return root;
}
int le[1005],maxl;
void level(int root,int h)
{
	if(root==-1)return;
	le[root]=h;
	maxl=max(maxl,h);
	if(l[root]!=-1) level(l[root],h+1);
	if(r[root]!=-1) level(r[root],h+1);
}
int main()
{
	int n,i,j;
	memset(l,-1,sizeof l);
	memset(r,-1,sizeof r);
	scanf("%d",&n);
	for(i=1;i<=n;i++)
	scanf("%d",&in[i]);
	for(i=1;i<=n;i++)
	scanf("%d",&post[i]);
	int root=post[n];
	dfs(1,n,1,n);
	level(root,1);
	queue<int> q;
	vector<int> v[1005]; 
	q.push(root);
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		v[le[u]].push_back(u);
		if(l[u]!=-1)q.push(l[u]);
		if(r[u]!=-1)q.push(r[u]);
	}
	printf("%d",root);
	for(i=2;i<=maxl;i++)
	{
		if(i%2==0)
		{
			for(j=0;j<v[i].size();j++)
			printf(" %d",v[i][j]);
		}	
		else
		{
			for(j=v[i].size()-1;j>=0;j--)
			printf(" %d",v[i][j]);
		}
	}
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章