浙大網課數據結構PTA 01-複雜度2 Maximum Subsequence Sum (25 分)

Given a sequence of K integers { N
​1
​​ , N
​2
​​ , …, N
​K
​​ }. A continuous subsequence is defined to be { N
​i
​​ , N
​i+1
​​ , …, N
​j
​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4

題解(c語言):
注意體重的各種情況的輸出結果,比如全爲0,全爲負數和0,全爲正

#include<stdio.h>

int main(){
	int n,i,a[100001];
	scanf("%d",&n);
	for(i=0;i<n;i++){
		scanf("%d",a+i);
	}
	int max=0,tempmax=0;
	int res1[2]={0,0},res2=0; 
	int flag0=0;
	for(i=0;i<n;i++){
		tempmax+=a[i];
		if(tempmax<0){
			tempmax=0;
			res1[1]=i+1;
		}
		if(a[i]==0)
			flag0=1;
		if(tempmax>max){
			max=tempmax;
			res1[0]=res1[1];
			res2=i;
		}
	}
	if(max>0&res1[1]<res2)
		printf("%d %d %d",max,a[res1[1]],a[res2]); 
	else if(max>0)
		printf("%d %d %d",max,a[res1[0]],a[res2]);
	else if(max==0&&flag0==1)
		printf("0 0 0");
	else
		printf("0 %d %d",a[0],a[n-1]);
	return 0;
}``

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章