Desert(HDU 5703)

Description

A tourist gets lost in the desert with n liters of water. He drinks positive integer units of water each day.

Write a program to calculate how many different ways the tourist can drink up the water.

 

Input

The first line contains the number of test cases T(T≤10) .
Next T lines contain the number n(1≤n≤1000000)  for each test case.

 

Output

Output consists of T lines.
Each line contains the binary number which represents number of different ways to finish up the water specified in the test case.

 

Sample Input


 

1

3

 

Sample Output


 

100

Hint

 3 liters of water can be comsumed in four different ways show in the following. 1. 1 1 1 2. 1 2 3. 2 1 4. 3 If we write 4 in binary, it's 100.
#include<bits/stdc++.h>
typedef long long ll;
using namespace std;
int main()
{
    int t;
    while(cin>>t){
        while(t--){
            int n;
            cin>>n;
            cout<<1;
            for(int i=1;i<n;++i){
                cout<<0;
            }
            cout<<endl;
        }
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章