poj1326解題報告

Mileage Bank
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 13705   Accepted: 5713

Description

Mileage program of ACM (Airline of Charming Merlion) is really nice for the travelers flying frequently. Once you complete a flight with ACM, you can earn ACMPerk miles in your ACM Mileage Bank depended on mileage you actual fly. In addition, you can use the ACMPerk mileage in your Mileage Bank to exchange free flight ticket of ACM in future. 



The following table helps you calculate how many ACMPerk miles you can earn when you fly on ACM. 
When you fly ACM		 Class Code	          You'll earn

 

First Class			 F		 Actual mileage + 100% mileage Bonus

 

Business Class		   	 B		 Actual mileage + 50% mileage Bonus

 

Economy Class			 Y

1-500 miles					 500 miles

500+ miles					 Actual mileage

It's shown that your ACMPerk mileage consists of two parts. One is your actual flight mileage (the minimum ACMPerk mileage for Economy Class for one flight is 500 miles), the other is the mileage bonus (its accuracy is up to 1 mile) when you fly in Business Class and First Class. For example, you can earn 1329 ACMPerk miles, 1994 ACMPerk miles and 2658 ACMPerk miles for Y, B or F class respectively for the fly from Beijing to Tokyo (the actual mileage between Beijing and Tokyo is 1329 miles). When you fly from Shanghai to Wuhan, you can earn ACMPerk 500 miles for economy class and ACMPerk 650 miles for business class (the actual mileage between Shanghai and Wuhan is 433 miles). 



Your task is to help ACM build a program for automatic calculation of ACMPerk mileage. 

Input

The input file contains several data cases. Each case has many flight records, each per line. The flight record is in the following format: 

OriginalCity DistanceCity ActualMiles ClassCode 

Each case ends with a line of one zero. 

A line of one # presents the end of the input file. 

Output

Output the summary of ACMPerk mileages for each test case, one per line.

Sample Input

Beijing Tokyo 1329 F
Shanghai Wuhan 433 Y
0
#

Sample Output

3158

代碼:

#include<iostream>
#include<string>
using namespace std;
int main()
{
string st1,st2;
char ch;
int length,sum=0;
    while (cin>>st1)
{
if (st1=="0") 
{
cout<<fixed<<sum<<endl;
sum=0;
continue;
}
else if (st1=="#") {break;}
else 
{
cin>>st2>>length>>ch;
       if (ch=='F')
{
       length=length*2;
   sum+=length;
}
   if (ch=='B')
{
sum+=length;
       sum+=(length*1.0/2.0+0.5);
   
}
   if (ch=='Y')
{
   if (length<500) {length=500;}
       sum+=length;
}
}


}
   return 0;
}

本題只要注意B時候的四捨五入,在最後結尾時,判斷0時需要返回重新輸入一次st1,再來判斷是否爲#,最最重要的返回是一定要把sum的值清0,我找了好久才發現這個小問題,總的來說本題目不難,只需要細心的做下去,應該一次就能a掉~


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章