The mook jong(HDU 5366)

Description

![](../../data/images/C613-1001-1.jpg)

ZJiaQ want to become a strong man, so he decided to play the mook jong。ZJiaQ want to put some mook jongs in his backyard. His backyard consist of n bricks that is 1*1,so it is 1*n。ZJiaQ want to put a mook jong in a brick. because of the hands of the mook jong, the distance of two mook jongs should be equal or more than 2 bricks. Now ZJiaQ want to know how many ways can ZJiaQ put mook jongs legally(at least one mook jong).

 

Input

There ar multiply cases. For each case, there is a single integer n( 1 < = n < = 60)

 

Output

Print the ways in a single line for each case.

 

Sample Input


 

1

2

3

4

5

6

 

Sample Output


 

1

2

3

5

8

12

#include<bits/stdc++.h>
typedef long long lint;
using namespace std;
lint a[70];
int main()
{
    int n,m;
    memset(a,0,sizeof(a));
    int i;
    a[1]=1;
    int ans=1;
    a[2]=2;
    a[3]=3;
    for(i=4;i<65;++i){
        a[i]=a[i-1]+a[i-3]+1;
        ++ans;
    }
    while(cin>>n){
        cout<<a[n]<<endl;
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章