UVA 題目11300 - Spreading the Wealth

Problem

A Communist regime is trying to redistribute wealth in a village. They have have decided to sit everyone around a circular table. First, everyone has converted all of their properties to coins of equal value, such that the total number of coins is divisible by the number of people in the village. Finally, each person gives a number of coins to the person on his right and a number coins to the person on his left, such that in the end, everyone has the same number of coins. Given the number of coins of each person, compute the minimum number of coins that must be transferred using this method so that everyone has the same number of coins.

The Input

There is a number of inputs. Each input begins with n(n<1000001), the number of people in the village. nlines follow, giving the number of coins of each person in the village, in counterclockwise order around the table. The total number of coins will fit inside an unsigned 64 bit integer.

The Output

For each input, output the minimum number of coins that must be transferred on a single line.

Sample Input

3
100
100
100
4
1
2
5
4

Sample Output

0
4

【思路】:




C0 = 0
C1 = A1 - M = C0 + A1 - M
C2 = A1 - M + A2 - M = C1 + A2 - M
............
Cn = An-1 - M + An - M = Cn-1 + An - M

規律:Cn  = Cn-1 + An - M

【代碼】:

 
/*********************************
*   日期:2013-4-21
*   作者:SJF0115
*   題號: 題目11300 - Spreading the Wealth
*   來源:http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=25&page=show_problem&problem=2275
*   結果:AC
*   來源:UVA
*   總結:
**********************************/
#include<stdio.h>
#include<stdlib.h>

int Money[1000001],C[1000001];

int cmp(const void *a,const void *b){
	return *(int *)a - *(int *)b;
}
//絕對值
int abs(int a,int b){
	if(a < b){
		return b - a;
	}
	else{
		return a - b;
	}
}

int main ()
{
	long long int i,N,Min,Sum,M;
	//freopen("C:\\Users\\XIAOSI\\Desktop\\acm.txt","r",stdin);
	while(scanf("%lld",&N) != EOF){
		Sum = 0;
		Min = 0;
		//N個人
		for(i = 0;i < N;i++){
			scanf("%d",&Money[i]);
			Sum += Money[i];
		}
		//平均值
		M = Sum / N;
		C[0] = 0;
		//初始化C數組
		for(i = 1;i < N;i++){
			C[i] = C[i-1] + Money[i] - M;
		}
		//排序,選擇中位數
		qsort(C,N,sizeof(int),cmp);
		long long int x1 = C[N/2];
		//計算轉移的金幣數
		for(i = 0;i < N;i++){
			Min += abs(x1,C[i]);
		}
		printf("%lld\n",Min);
	}
	return 0;
}



注意:int越界 用long long int 













發佈了493 篇原創文章 · 獲贊 115 · 訪問量 314萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章