數據結構實驗之鏈表一:順序建立鏈表 (sdut oj)


數據結構實驗之鏈表一:順序建立鏈表

Time Limit: 1000MS Memory Limit: 65536KB


Problem Description

輸入N個整數,按照輸入的順序建立單鏈表存儲,並遍歷所建立的單鏈表,輸出這些數據。


Input

第一行輸入整數的個數N;
第二行依次輸入每個整數。


Output

輸出這組整數。


Example Input

8
12 56 4 6 55 15 33 62


Example Output

12 56 4 6 55 15 33 62


Hint

不得使用數組!

Author








參考代碼


#include<stdio.h>
#include<stdlib.h>

struct node
{
    int data;
    struct node *next;
};

int main()
{
    int n;
    struct node *head,*p,*tail;
    scanf("%d",&n);
    head = (struct node *)malloc(sizeof(struct node));
    head->next = NULL;
    tail = head;
    while(n--)
    {
        p = (struct node *)malloc(sizeof(struct node));
        scanf("%d",&p->data);
        p->next = tail->next;
        tail->next = p;
        tail = p;
    }
    p = head->next;
    printf("%d",p->data);
    p = p->next;
    while(p)
    {
        printf(" %d",p->data);
        p = p->next;
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章