FZU 2150 Fire Game

Fire Game

https://vjudge.net/problem/FZU-2150
Fat brother and Maze are playing a kind of special (hentai) game on an N*M board (N rows, M columns). At the beginning, each grid of this board is consisting of grass or just empty and then they start to fire all the grass. Firstly they choose two grids which are consisting of grass and set fire. As we all know, the fire can spread among the grass. If the grid (x, y) is firing at time t, the grid which is adjacent to this grid will fire at time t+1 which refers to the grid (x+1, y), (x-1, y), (x, y+1), (x, y-1). This process ends when no new grid get fire. If then all the grid which are consisting of grass is get fired, Fat brother and Maze will stand in the middle of the grid and playing a MORE special (hentai) game. (Maybe it’s the OOXX game which decrypted in the last problem, who knows.)

You can assume that the grass in the board would never burn out and the empty grid would never get fire.

Note that the two grids they choose can be the same.

Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains two integers N and M indicate the size of the board. Then goes N line, each line with M character shows the board. “#” Indicates the grass. You can assume that there is at least one grid which is consisting of grass in the board.

1 <= T <=100, 1 <= n <=10, 1 <= m <=10

Output

For each case, output the case number first, if they can play the MORE special (hentai) game (fire all the grass), output the minimal time they need to wait after they set fire, otherwise just output -1. See the sample input and output for more details.

Sample Input

4
3 3
.#.
###
.#.
3 3
.#.
#.#
.#.
3 3
...
#.#
...
3 3
###
..#
#.#

Sample Output

Case 1: 1
Case 2: -1
Case 3: 0
Case 4: 2

C++

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>

using namespace std;

const int MAXN = 10 + 5;
const int INF = 0x3f3f3f3f;
char maze[MAXN][MAXN];
bool vis[MAXN][MAXN];
int dir[4][2] = {0,1,1,0,0,-1,-1,0};
int T, n, m;
int cnt;

struct node{
	int x, y, step;
}arr[100 + 5];

bool judge(int x, int y)
{
	return x >= 0 && x < n && y >= 0 && y < m;
}

int bfs(node x, node y)
{
	queue<node> q;
	memset(vis, false, sizeof(vis));
	int tmp;
	if(x.x == y.x && x.y == y.y) tmp = cnt - 1;
	else tmp = cnt - 2;
	node now, next;
	now.x = x.x; now.y = x.y; now.step = 0;
	vis[x.x][x.y] = true;
	q.push(now);
	now.x = y.x; now.y = y.y; now.step = 0;
	vis[y.x][y.y] = true;
	q.push(now);
	while(!q.empty())
	{
		now = q.front();
		q.pop();
		for(int i = 0; i < 4; i ++)
		{
			int tx = now.x + dir[i][0];
			int ty = now.y + dir[i][1];
			if(judge(tx, ty) && !vis[tx][ty] && maze[tx][ty] == '#')
			{
				vis[tx][ty] = true;
				next.x = tx;
				next.y = ty;
				next.step = now.step + 1;
				q.push(next);
				tmp --;
			}
		}
	}
	if(tmp)
		return INF;
	return now.step;
}

int main()
{
	scanf("%d", &T);
	for(int t = 1; t <= T; t ++)
	{
		scanf("%d%d", &n, &m);
		cnt = 0;
		getchar();
		for(int i = 0; i < n; i ++)
		{
			for(int j = 0; j < m; j ++)
			{
				scanf("%c", &maze[i][j]);
				if(maze[i][j] == '#')
				{
					arr[cnt].x = i;
					arr[cnt].y = j;
					cnt ++;
				}
			}
			getchar();
		}
		int MIN = INF;
		for(int i = 0; i < cnt; i ++){
			for(int j = i; j < cnt; j ++){
				MIN = min(bfs(arr[i], arr[j]), MIN);
			}
		}
		if(MIN == INF)
			printf("Case %d: -1\n", t);
		else
			printf("Case %d: %d\n", t, MIN);
	}
	return 0;
}
發佈了29 篇原創文章 · 獲贊 1 · 訪問量 3282
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章