POJ 3279 Fliptile

Fliptile

https://vjudge.net/problem/POJ-3279
Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word “IMPOSSIBLE”.

Input

Line 1: Two space-separated integers: M and N
Lines 2… M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1… M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

C++

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int n, m;
int maze[20][20], tmp[20][20], cnt[20][20], ans[20][20];
int dir[5][2] = {0,1,1,0,0,0,0,-1,-1,0};
const int INF = 0x3f3f3f3f;
int minn = INF;
bool flag = false;

void flip(int a[][20], int x, int y)
{
	for(int i = 0; i < 5; i ++){
		int tx = x + dir[i][0];
		int ty = y + dir[i][1];
		if(tx >= 0 && tx < n && ty >= 0 && ty < m)
		{
			a[tx][ty] = 1 - a[tx][ty];
		}		
	}
}

int check()
{
	int t = 0;
	for(int i = 1; i < n; i ++){
		for(int j = 0; j < m; j ++){
			if(tmp[i - 1][j]){
				flip(tmp, i, j);
				cnt[i][j] = 1;
			}
			else cnt[i][j] = 0;
		}
	}
	for(int i = 0; i < m; i ++){
		if(tmp[n - 1][i]) return INF;
	}
	for(int i = 0; i < n; i ++){
		for(int j = 0; j < m; j ++){
			if(cnt[i][j]) t ++;
		}
	}
	return t;
}

void dfs(int col){
	if(col == m){
		for(int i = 0; i < n; i ++)
			for(int j = 0; j < m; j ++)
				tmp[i][j] = maze[i][j];
		int t = check();
		if(t < minn){
			minn = t;
			flag = true;
			for(int i = 0; i < n; i ++)
				for(int j = 0; j < m; j ++)
					ans[i][j] = cnt[i][j];
		}
		return;
	}
	dfs(col + 1);	
	flip(maze, 0, col);
	cnt[0][col] = 1;
	dfs(col + 1);
	flip(maze, 0, col);
	cnt[0][col] = 0; 
}

int main()
{
	scanf("%d%d", &n, &m);
	for(int i = 0; i < n; i ++){
		for(int j = 0; j < m; j ++){
			scanf("%d", &maze[i][j]);
		}
	}
	dfs(0);
	if(flag){
		for(int i = 0; i < n; i ++){
			for(int j = 0; j < m - 1; j ++){
				printf("%d ", ans[i][j]);
			}
			printf("%d\n", ans[i][m - 1]);
		}
	}
	else printf("IMPOSSIBLE\n");
	return 0;
}
發佈了29 篇原創文章 · 獲贊 1 · 訪問量 3283
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章