poj3071之概率DP

Football
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 2667   Accepted: 1361

Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all i ≠ j, and pii = 0.0 for all i. The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the double data type instead of float.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

Sample Input

2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output

2
/*分析:假設dp[i][j]表示進行第i次比賽j贏得概率
則主要在於計算第i次比賽可能與j相鄰的隊伍t並且本次是與t比賽 
然後dp[i][j]+=dp[i-1][j]*dp[i-1][t]*p[j][t]
對於t如何算?
假設隊伍id:
0 1 2 3 4 5 6 7
對於第一輪比賽相對上一輪比賽:
0屬於第一個贏家,1屬於第二個贏家,2屬於第三個贏家,3屬於第四個贏家... 
第一次比賽後:
0/1 2/3 4/5 6/7
對於第二輪比賽相對上一輪比賽:
0/1屬於第一個贏家,2/3屬於第二個贏家...
可以發現規律都是:
第奇數個贏家和前一個贏家比賽
第偶數個贏家和後一個贏家比賽
也不難發現規律,對於第j個隊伍在第i次比賽
屬於第j/(2^(i-1))個贏家//從0開始 
*/
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#include <queue>
#include <algorithm>
#include <map>
#include <cmath>
#include <iomanip>
#define INF 99999999
typedef long long LL;
using namespace std;

const int MAX=(1<<7)+10;
const int N=10+10;
int n;
double p[MAX][MAX],dp[N][MAX];//dp[i][j]表示第i回合j勝利的概率

int main(){
	while(~scanf("%d",&n),n != -1){
		int bit=1<<n;
		for(int i=0;i<bit;++i){
			for(int j=0;j<bit;++j)scanf("%lf",&p[i][j]);
		}
		memset(dp,0,sizeof dp);
		for(int i=0;i<bit;++i)dp[0][i]=1;
		for(int i=1;i<=n;++i){
			for(int j=0;j<bit;++j){
				int t=j>>(i-1);//j經歷i-1次屬於第t個贏家 
				if(t&1){//j爲奇數贏家,本次將與第j-1個贏家比賽 
					for(int k=t*(1<<(i-1))-1;k>=(t-1)*(1<<(i-1));--k){
						dp[i][j]+=dp[i-1][j]*dp[i-1][k]*p[j][k];
					}
				}else{//j爲偶數贏家,本次將與第j+1個贏家比賽 
					for(int k=(t+1)*(1<<(i-1));k<(t+2)*(1<<(i-1));++k){
						dp[i][j]+=dp[i-1][j]*dp[i-1][k]*p[j][k];
					}
				}
			}
		}
		int id=0;
		for(int i=0;i<bit;++i){
			if(dp[n][i]>dp[n][id])id=i;
		}
		printf("%d\n",id+1);
	}
	return 0;
}



發佈了314 篇原創文章 · 獲贊 26 · 訪問量 50萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章