Pat(A) 1106. Lowest Price in Supply Chain (25)

原題目:

原題鏈接:https://www.patest.cn/contests/pat-a-practise/1106

1106. Lowest Price in Supply Chain (25)


A supply chain is a network of retailers(零售商), distributors(經銷商), and suppliers(供應商)– everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N-1, and the root supplier’s ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

Ki ID[1] ID[2] … ID[Ki]

where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID’s of these distributors or retailers. Kj being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 1010.

Sample Input:
10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0
2 6 1
1 8
0
0
0
Sample Output:
1.8362 2

題目大意

有一系列經銷商,除了根經銷商,每個經銷商有且只有一個上級,從上級拿到貨之後會比進貨價多r%賣出。問零售商中(沒有下級)中最低價會是多少,有幾個賣最低價的零售商。
輸入數據爲經銷商數N(經銷商標記爲0~N-1),最原始價格,比例r
後N行爲第i個經銷商的下級數以及其下級。。

解題報告

本題與Pat甲級的1090題:1090. Highest Price in Supply Chain (25)有相似之處。
1090求樹的深度,並求出該層有多少節點,求深度用的dfs。
本題求的是層次最小的葉子節點的層數,並求出該層多少葉子節點,用的是bfs。

代碼

#include "iostream"
#include "vector"
#include "queue"
#include "cmath"
using namespace std;

vector<vector<int>> G;

int N;
double P,r;
int ansLevel,ansNum;

void init(){
    cin>>N>>P>>r;
    G.resize(N);
    int i,j,k,x;
    for(i = 0; i < N; i++){
        cin>>k;
        for(j = 0; j < k; j++){
            cin>>x;
            G[i].push_back(x);
        }
    }
}

void bfs(){
    queue<int> que;
    bool flag = false;
    int cnt = 0,num = 1;
    int nextNum = 0;
    ansLevel = 1;
    ansNum = 0;
    que.push(0);
    int x,i;
    while(!que.empty()){
        x = que.front();
        que.pop();
        cnt ++;
        if(G[x].size() == 0){
            flag = true;
            ansNum ++;
        }
        for(i = 0; i < G[x].size(); i++){
            que.push(G[x][i]);
            nextNum ++;
        }
        if(cnt == num){
            if(flag)
                return;
            ansLevel ++;
            num = nextNum;
            nextNum = 0;
            cnt = 0;
        }
    }
}

int main(){
    init();
    bfs();
    printf("%.4f %d\n",P * pow(1+ r / 100,ansLevel - 1),ansNum);
    system("pause");
}
發佈了58 篇原創文章 · 獲贊 114 · 訪問量 158萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章