Pat(A) 1107. Social Clusters (30)

原題目:

原題鏈接:https://www.patest.cn/contests/pat-a-practise/1107

1107. Social Clusters (30)


When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A “social cluster” is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (<=1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

Ki: hi[1] hi[2] … hi[Ki]

where Ki (>0) is the number of hobbies, and hi[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4
Sample Output:
3
4 3 1

題目大意

每個人有多個愛好,擁有相同愛好的人爲同一簇。問有多少簇人,按人數有大到小輸出每個簇的人數。

解題報告

並查集的題目,將擁有同一愛好的人歸爲同一集合。
ans[i]表示以i爲根的一簇的人數,ans[0]表示總的簇數。
pre[i]表示上一個有愛好i的人的編號。

代碼

#include "iostream"
#include "vector"
#include "algorithm"
using namespace std;

int father[1001] = {0};
int pre[1001] = {0}; // pre[i] means the last person who has a hobby i
int N;
vector<int> ans;

int getF(int x){
    int a = x,t;
    while(x != father[x]){
        x = father[x];
    }
    while(a != father[a]){
        t = a;
        a = father[a];
        father[t] = x;
    }
    return x;
}

void Union(int a,int b){
    int fa = getF(a);
    int fb = getF(b);
    father[fb] = fa;
}

void init(){
    scanf("%d",&N);
    int i,k,j,x;
    ans.resize(N + 1,0);
    for(i = 0; i < 1001; i++)
        father[i] = i;
    for(i = 1; i <= N; i++){
        scanf("%d: ",&k);
        for(j = 0; j < k; j ++){
            scanf("%d",&x);
            if(pre[x] == 0)
                pre[x] = i;
            Union(i,getF(pre[x]));
        }
    }
}

void cal(){
    int  i,f;
    for(i = 1; i <= N; i++){
        f = getF(i);
        if( f == i)
            ans[0]++;
        ans[getF(i)] ++;
    }
    sort(ans.begin() + 1,ans.end());
}

int main(){
    init();
    cal();
    printf("%d\n",ans[0]);
    if(ans[0]){
        printf("%d",ans[ans.size() - 1]);
        for(int i = ans.size() - 2,k = 1; k < ans[0]; i--,k++)
            printf(" %d",ans[i]);
        printf("\n");
    }
    system("pause");;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章