Pat(A) 1094. The Largest Generation (25)

原題目:

原題鏈接:https://www.patest.cn/contests/pat-a-practise/1094

1094. The Largest Generation (25)


A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (< N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] … ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID’s of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:
23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18
Sample Output:
9 4

題目大意

給一個家族系譜的樹,求人數最多的那一代。
首行爲N,M,表示N個人和M個家庭。
後M行格式爲,家族成員,其孩子數,孩子1,孩子2……

解題報告

樹的層次遍歷,用BFS,隊列優化。記錄每層的人員數。

代碼

#include "iostream"
#include "vector"
#include "queue"
using namespace std;

int N,M;
vector<vector<int>> G;
int level,ans;


void init(){
    cin>>N>>M;
    G.resize(N + 1);
    int i,k,j,x;
    for(i = 0; i < M; i++){
        cin>>x>>k;
        G[x].resize(k);
        for(j = 0; j < k; j++){
            cin>>G[x][j];
        }
    }
}

void bfs(){
    int root = 1;
    int x,i;
    queue<int> que;
    level = 1;
    ans = 1;

    int numInLevel = 0,numInNextLevel = 0,num = 0,tempLevel = 0;

    que.push(root);
    numInLevel ++;
    numInNextLevel;
    tempLevel ++;
    while(!que.empty()){
        x = que.front();
        que.pop();
        num ++;
        for(i = 0; i < G[x].size(); i++){
            que.push(G[x][i]);
            numInNextLevel ++;
        }
        if(num == numInLevel){
            if(numInNextLevel > ans){
                level = tempLevel + 1;
                ans = numInNextLevel;
            }
            tempLevel ++;
            numInLevel = numInNextLevel;
            numInNextLevel = 0;
            num = 0;
        }
    }

}

int main(){
    init();
    bfs();
    printf("%d %d",ans,level);
    //system("pause");
}
發佈了58 篇原創文章 · 獲贊 114 · 訪問量 158萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章