Pat(A) 1092. To Buy or Not to Buy (20)

原題目:

原題鏈接:https://www.patest.cn/contests/pat-a-practise/1092

1092. To Buy or Not to Buy (20)


Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is “Yes”, please tell her the number of extra beads she has to buy; or if the answer is “No”, please tell her the number of beads missing from the string.

For the sake of simplicity, let’s use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.


這裏寫圖片描述
Figure 1

Input Specification:

Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.

Output Specification:

For each test case, print your answer in one line. If the answer is “Yes”, then also output the number of extra beads Eva has to buy; or if the answer is “No”, then also output the number of beads missing from the string. There must be exactly 1 space between the answer and the number.

Sample Input 1:
ppRYYGrrYBR2258
YrR8RrY
Sample Output 1:
Yes 8
Sample Input 2:
ppRYYGrrYB225
YrR8RrY
Sample Output 1:
No 2

題目大意

給定兩個串,看第一個串是否包含第二個串中所有的字符(包括個數),如果全部包含,計算多餘的字符數,如果不全包含,計算所缺的字符數。

解題報告

把字符對應成下標,統計第一個串每個字符的個數,統計第二個串每個字符的個數,然後進行比較

代碼

#include "iostream"
#include "map"
#include "string"
using namespace std;

map<char,int> c2i;

int eva[65];
int shop[65];
int more=0,miss=0;

void init(){
    string a,b;
    cin>>a>>b;
    int i,id;
    for(i = '0'; i <= '9'; i++){ // 此時i可理解爲char型
        id = i - '0';
        c2i[i] = id;
    }
    for(i = 'a'; i <= 'z'; i++){ // 此時i可理解爲char型
        id = i - 'a' + 10;
        c2i[i] = id;
    }
    for(i = 'A'; i <= 'Z'; i++){ // 此時i可理解爲char型
        id = i - 'A' + 36;
        c2i[i] = id;
    }
    for(i = 0; i < a.length(); i++){
        shop[c2i[a[i]]] ++;
    }
    for(i = 0; i < b.length(); i++){
        eva[c2i[b[i]]] ++;
    }
}

void cal(){
    for(int i= 0; i < 62; i++){
        if(shop[i] > eva[i])
            more += shop[i] - eva[i];
        else
            miss += eva[i] - shop[i];
    }
}

int main(){
    init();
    //prin();
    cal();
    if(miss > 0)
        printf("No %d",miss);
    else
        printf("Yes %d",more);
    //system("pause");
}
發佈了58 篇原創文章 · 獲贊 114 · 訪問量 158萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章