Pat(A) 1095. Cars on Campus (30)

原題目:

原題鏈接:https://www.patest.cn/contests/pat-a-practise/1095

1095. Cars on Campus (30)


Zhejiang University has 6 campuses and a lot of gates. From each gate we can collect the in/out times and the plate numbers of the cars crossing the gate. Now with all the information available, you are supposed to tell, at any specific time point, the number of cars parking on campus, and at the end of the day find the cars that have parked for the longest time period.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<= 10000), the number of records, and K (<= 80000) the number of queries. Then N lines follow, each gives a record in the format

plate_number hh:mm:ss status

where plate_number is a string of 7 English capital letters or 1-digit numbers; hh:mm:ss represents the time point in a day by hour:minute:second, with the earliest time being 00:00:00 and the latest 23:59:59; and status is either in or out.

Note that all times will be within a single day. Each “in” record is paired with the chronologically next record for the same car provided it is an “out” record. Any “in” records that are not paired with an “out” record are ignored, as are “out” records not paired with an “in” record. It is guaranteed that at least one car is well paired in the input, and no car is both “in” and “out” at the same moment. Times are recorded using a 24-hour clock.

Then K lines of queries follow, each gives a time point in the format hh:mm:ss. Note: the queries are given in ascending order of the times.

Output Specification:

For each query, output in a line the total number of cars parking on campus. The last line of output is supposed to give the plate number of the car that has parked for the longest time period, and the corresponding time length. If such a car is not unique, then output all of their plate numbers in a line in alphabetical order, separated by a space.

Sample Input:
16 7
JH007BD 18:00:01 in
ZD00001 11:30:08 out
DB8888A 13:00:00 out
ZA3Q625 23:59:50 out
ZA133CH 10:23:00 in
ZD00001 04:09:59 in
JH007BD 05:09:59 in
ZA3Q625 11:42:01 out
JH007BD 05:10:33 in
ZA3Q625 06:30:50 in
JH007BD 12:23:42 out
ZA3Q625 23:55:00 in
JH007BD 12:24:23 out
ZA133CH 17:11:22 out
JH007BD 18:07:01 out
DB8888A 06:30:50 in
05:10:00
06:30:50
11:00:00
12:23:42
14:00:00
18:00:00
23:59:00
Sample Output:
1
4
5
2
1
0
1
JH007BD ZD00001 07:20:09

題目大意

給出車輛出入記錄,判斷某一時刻停車的數量以及一天內停車時長最多的車輛。
首行N,K表示N條記錄,K次詢問。
後N行爲車輛出入記錄。
再K行爲詢問時間。
輸出每個時間的停車數,以及一天內停車時長最多的車輛車牌,若不唯一,按車牌順序輸出。
注意:
給出N條車輛記錄,但有用的卻不一定有N條,唯有配對成功(in和out)才視爲有效記錄。比如若出現in in out out情況,第一個in和第二個out因無法配對不視爲有效記錄。

解題報告

先按第一關鍵字車牌,第二關鍵字時間排序,篩選出有效車輛出入記錄。
再對有效的進行按時間排序。

代碼

#include "iostream"
#include "algorithm"
#include "vector"
#include "string"
#include "map"
using namespace std;

struct node{
    string car;
    int time;
    string status;
};

bool cmp(struct node a,struct node b){
    return a.time < b.time;
}
bool cmpWithCarNum(struct node a,struct node b){
    if(a.car != b.car)
        return a.car < b.car;
    return a.time < b.time;
}

int N,K;
int maxTime = 0;
map<string,int> parkInTime;
map<string,bool> parkStatus;
vector<struct node> records;
vector<struct node> realRecords;
map<string,int> parkTime;

void init(){
    scanf("%d %d",&N,&K);
    int i;
    string car,status;
    int h,m,s;
    char c1[10];
    char c2[10];
    for(i = 0; i < N; i ++){
        scanf("%s %d:%d:%d %s",c1,&h,&m,&s,c2);
        car = string(c1);
        status = string(c2);
        struct node temp;
        temp.car = car;
        temp.time = h * 3600 + m * 60 + s;
        temp.status = status;
        records.push_back(temp);
    }
}

void cal(){
    parkStatus.clear();
    int i,j;
    int h,m,s,time;
    char c;
    int carNum = 0;
    for(i = 0,j = 0; i < K; i++){
        scanf("%d:%d:%d",&h,&m,&s);
        time = h * 3600 + m * 60 + s;
        while(j < realRecords.size() && realRecords[j].time <= time){
            if(realRecords[j].status == "in"){
                parkStatus[realRecords[j].car] = true;
                parkInTime[realRecords[j].car] = realRecords[j].time;
                carNum ++;
            }else if(parkStatus[realRecords[j].car]){
                parkStatus[realRecords[j].car] = false;
                parkTime[realRecords[j].car] += realRecords[j].time - parkInTime[realRecords[j].car];
                maxTime = max(maxTime,parkTime[realRecords[j].car]);
                carNum --;
            }
            j ++;
        }
        printf("%d\n",carNum);
    }
    while(j < realRecords.size()){
        if(realRecords[j].status == "in"){
            parkStatus[realRecords[j].car] = true;
            parkInTime[realRecords[j].car] = realRecords[j].time;
        }else if(parkStatus[realRecords[j].car]){
            parkStatus[realRecords[j].car] = false;
            parkTime[realRecords[j].car] += realRecords[j].time - parkInTime[realRecords[j].car];
            maxTime = max(maxTime,parkTime[realRecords[j].car]);
        }
        j ++;
    }
}

void fil(){
    for (int i = 0; i < records.size()-1; i++){
        if(records[i].car != records[i+1].car){
            continue;
        }
        if(records[i].status == "in" && records[i+1].status == "out"){
            realRecords.push_back(records[i ++]);
            realRecords.push_back(records[i]);
        }
        continue;
    }
}

int main(){
    init();
    sort(records.begin(),records.end(),cmpWithCarNum);
    fil();
    sort(realRecords.begin(),realRecords.end(),cmp);
    cal();
    for(auto it = parkTime.begin();it != parkTime.end();it++){
        if(maxTime == it->second)
            printf("%s ",it->first.c_str());
    }
    printf("%02d:%02d:%02d\n",maxTime/3600,maxTime%3600/60,maxTime%60);
    system("pause");

}
發佈了58 篇原創文章 · 獲贊 114 · 訪問量 158萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章