Pat(A) 1101. Quick Sort (25)

原題目:

原題鏈接:https://www.patest.cn/contests/pat-a-practise/1101

1101. Quick Sort (25)


There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N = 5 and the numbers 1, 3, 2, 4, and 5. We have:

1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
and for the similar reason, 4 and 5 could also be the pivot.
Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 105). Then the next line contains N distinct positive integers no larger than 109. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:
5
1 3 2 4 5
Sample Output:
3
1 4 5

題目大意

給出一串數,求出快排中合適的分界點。
合適的意思是左邊的數都比它小,右邊的數都比它大。

解題報告

用minInR[i]表示在第i個數的右邊最小的那個數,maxNum表示當前位置的左邊最大的那個數。
如果一個數符合maxNum < data[i] < minInR[i],那麼這個數肯定是符合條件的。應當計入。

代碼

#include "iostream"
#include "vector"
using namespace std;

int N;
long long data[100000 + 5];
long long minInR[100000 + 5];
vector<long long> ans;

void init(){
    cin>>N;
    int i;
    for(i = 0; i < N; i++){
        cin>>data[i];
    }
}

void cal(){
    int i;
    minInR[N -1] = 0x3FFFFFFF;
    for(i = N - 2; i >= 0; i--)
        minInR[i] = min(data[i + 1],minInR[i + 1]);
    long long maxNum = -1; // current max num ; the largest num before i
    for(i = 0; i < N; i++){
        if(data[i] > maxNum && data[i] < minInR[i]){
            ans.push_back(data[i]);
        }
        maxNum = max(maxNum,data[i]);
    }
}

void printAns(){
    int k =ans.size();
    cout<<k<<endl;
    if(k){
        cout<<ans[0];
        for(int i = 1; i< k; i++){
            cout<<" "<<ans[i];
        }
    }
    cout<<endl;
}

int main(){
    init();
    cal();
    printAns();
    system("pause");
}
發佈了58 篇原創文章 · 獲贊 114 · 訪問量 158萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章