Pat(A) 1090. Highest Price in Supply Chain (25)

原題目:

原題鏈接:https://www.patest.cn/contests/pat-a-practise/1090

1090. Highest Price in Supply Chain (25)


A supply chain is a network of retailers(零售商), distributors(經銷商), and suppliers(供應商)– everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence they are numbered from 0 to N-1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number Si is the index of the supplier for the i-th member. Sroot for the root supplier is defined to be -1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 1010.

Sample Input:
9 1.80 1.00
1 5 4 4 -1 4 5 3 6
Sample Output:
1.85 2

題目大意

有一系列經銷商,除了根經銷商,每個經銷商有且只有一個上級,從上級拿到貨之後會比進貨價多r%賣出。問最高價會是多少,有幾個賣最高價的經銷商。
輸入數據爲經銷商數N(經銷商標記爲0~N-1),最原始價格,比例r
下一行爲每個經銷商的上級,上級爲-1表示根經銷商。

解題報告

本題不難,dfs解決,困難的地方就是數據多,數組開不了太大,而且如果對於每個經銷商,搜索其下級需要遍歷n次,容易超時。
所以解決方案是存儲一個經銷商有哪些下級,而不是哪個是上級,以此來降低時間複雜度

代碼

#include "iostream"
#include "vector"
using namespace std;

vector< vector<int> > G;
vector<int> customer;
int N;
double P;
double r;
double ans;
int level,num,templevel;
int root;

void init(){
    cin>>N>>P>>r;
    G.resize(N);
    customer.resize(N,0);
    int x;
    for(int i = 0; i < N; i++){
        cin>>x;
        if(x == -1)
            root = i;
        else{
            customer[x]++;
            G[x].resize(customer[x],i);//這裏resize只會把增加的空間的值改變,相當於增加了一個位置,並置值爲i
        }

    }
    level = templevel = 0;
    num = 0;
}

void dfs(int r){
    int i,j;
    for(i = 0; i < customer[r]; i++){
        templevel ++;
        dfs(G[r][i]);
        templevel --;
    }
    if(!customer[r]){
        if(templevel > level){
            level = templevel;
            num = 1;
        }else if(templevel == level){
            num ++;
        }
    }
}

int main(){
    init();
    dfs(root);
    ans =P;
    for(int i =0;i < level; i++)
        ans *= 1 + r / 100;
    printf("%.2f %d",ans,num);
    system("pause");
}
發佈了58 篇原創文章 · 獲贊 114 · 訪問量 158萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章