hdu4493 Tutor 小數進位

Tutor

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 4144    Accepted Submission(s): 1084


Problem Description
Lilin was a student of Tonghua Normal University. She is studying at University of Chicago now. Besides studying, she worked as a tutor teaching Chinese to Americans. So, she can earn some money per month. At the end of the year, Lilin wants to know his average monthly money to decide whether continue or not. But she is not good at calculation, so she ask for your help. Please write a program to help Lilin to calculate the average money her earned per month.
 

Input
The first line contain one integer T, means the total number of cases. 
Every case will be twelve lines. Each line will contain the money she earned per month. Each number will be positive and displayed to the penny. No dollar sign will be included.
 

Output
The output will be a single number, the average of money she earned for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign without tail zero. There will be no other spaces or characters in the output.
 

Sample Input
2 100.00 489.12 12454.12 1234.10 823.05 109.20 5.27 1542.25 839.18 83.99 1295.01 1.75 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00
 

Sample Output
$1581.42 $100
 


#include <stdio.h>
#include <iostream>
#include <math.h>
using namespace std;

int main()
{
	int T, i;
	double x, sum;
	scanf("%d", &T);
	while (T--)
	{
		sum = 0;
		for (i = 1; i <= 12; i++)
		{
			scanf("%lf", &x);
			sum += x;
		}
		sum /= 12;
		int ans = sum * 100 + 0.5; //四捨五入
		printf("$");
		if (ans % 100 == 0)
			printf("%.0lf\n", 1.0 * ans / 100);
		else if (ans % 10 == 0)
			printf("%.1lf\n", 1.0 * ans / 100);
		else
			printf("%.2lf\n", 1.0 * ans / 100);
	}
	return 0;
}




發佈了198 篇原創文章 · 獲贊 8 · 訪問量 14萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章