FZU Problem 2150 - Fire Game

Problem Description

    Fat brother and Maze are playing a kind of special (hentai) game on an N*M board (N rows, M columns). At the beginning, each grid of this board is consisting of grass or just empty and then they start to fire all the grass. Firstly they choose two grids which are consisting of grass and set fire. As we all know, the fire can spread among the grass. If the grid (x, y) is firing at time t, the grid which is adjacent to this grid will fire at time t+1 which refers to the grid (x+1, y), (x-1, y), (x, y+1), (x, y-1). This process ends when no new grid get fire. If then all the grid which are consisting of grass is get fired, Fat brother and Maze will stand in the middle of the grid and playing a MORE special (hentai) game. (Maybe it’s the OOXX game which decrypted in the last problem, who knows.)
    You can assume that the grass in the board would never burn out and the empty grid would never get fire.
    Note that the two grids they choose can be the same.

Input

    The first line of the date is an integer T, which is the number of the text cases.
    Then T cases follow, each case contains two integers N and M indicate the size of the board. Then goes N line, each line with M character shows the board. “#” Indicates the grass. You can assume that there is at least one grid which is consisting of grass in the board.
1 <= T <=100, 1 <= n <=10, 1 <= m <=10

Output

    For each case, output the case number first, if they can play the MORE special (hentai) game (fire all the grass), output the minimal time they need to wait after they set fire, otherwise just output -1. See the sample input and output for more details.

Sample Input

43 3
.#.
###
.#.
3 3
.#.
#.#
.#.
3 3

#.#

3 3
###
..#
#.#

Sample Output

Case 1: 1
Case 2: -1
Case 3: 0
Case 4: 2

題目大意

一片空地上有很多方格,有的方格里有草,可以被點着,從兩個方格開始點火,這兩個方格可以相同,火每一秒會蔓延到旁邊的方格,問最少需要多少時間可以把所有有草的方格全部點燃,不能輸出-1,
由於數據範圍較小,可以每次任選兩個有草的點,然後從這兩個點開始Bfs,記錄用時最少的時間

代碼

#include <iostream>
#include <cstring>
#include <queue>
#include <vector>
#include <cstdio>
#include <algorithm>
using namespace std;
const int Inf = 1e9 + 5;

struct node {
    int x,y,depth;
};

vector <node>p;
char grid[12][12];
bool vis[12][12];

int dirx[4] = { 1, -1, 0, 0 };  
int diry[4] = { 0, 0, -1, 1 };  

int n, m, sum;
bool check(int x,int y)
{
    if (!vis[x][y] && grid[x][y] == '#' && x >= 0 && x < n && y >= 0 && y < m)
        return true;
    else
        return false; 
}

int Bfs(node node1,node node2)
{
    int total = 0;
    queue <node>q;
    while( !q.empty() ) q.pop();
    vis[node1.x][node1.y] = true;
    q.push(node1);

    vis[node2.x][node2.y] = true;
    q.push(node2);

    while( ! q.empty() )
    {
        node now = q.front();
        q.pop();
        ++total;
        if(total == sum)
            return now.depth;
        for(int i = 0; i < 4; ++i)
        {
            int nx = now.x + dirx[i];
            int ny = now.y + diry[i];
            if( check(nx, ny) )
            {
                node next;
                next.x = nx;
                next.y = ny;
                next.depth = now.depth + 1;
                q.push(next);
                vis[nx][ny] = true;
            }
        }
    }
    return Inf;
}
int main()
{
    int T;
    scanf("%d",&T);
    for(int _case = 1; _case <= T; ++_case)
    {
        p.clear();       //清空vector
        scanf("%d%d",&n,&m);
        for(int i = 0; i < n; ++i)
            scanf("%s",grid[i]);
        sum = 0;
        for(int i = 0; i < n; ++i)
            for(int j = 0; j < m; ++j)
            {
                if(grid[i][j] == '#')
                {
                    node pp;
                    pp.x = i;
                    pp.y = j;
                    pp.depth = 0;
                    p.push_back(pp);
                    ++sum;
                }
            }
        int ans = Inf;
        int _size = p.size();
        for(int i = 0; i < _size; ++i)
        {
            for(int j = i; j < _size; ++j)
            {
                memset(vis, false, sizeof vis);
                ans = min(ans,Bfs(p[i], p[j]));
            }
        }
        printf("Case %d: %d\n",_case, ans == Inf ? -1 : ans);
    }
    return 0;
}
發佈了48 篇原創文章 · 獲贊 17 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章