HDOJ 1513 Palindrome【迴文串&&滾動數組】

Palindrome

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5165    Accepted Submission(s): 1761


Problem Description
A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.
 

Input
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.
 

Output
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
 

Sample Input
5 Ab3bd
 

Sample Output
2
 

Source
 

Recommend
linle
 

這裏主要有一個迴文串的問題。一個序列的最長迴文子序列就是它和自己逆序的最長公共子序列(LCS)。

然後因爲5000太大了,開不了二維數組,所以我們可以用滾動數組,就是奇數偶數交叉記錄。因爲這個題只需要最後結果,所以中間過程被省去也沒有問題。


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[2][5010];
char ch1[5010],ch2[5010];
int main()
{
	int i,j,n;
	while(~scanf("%d",&n))
	{
		memset(dp,0,sizeof(dp));
		scanf("%s",ch1);
		for(i=0;i<n;i++)
			ch2[i]=ch1[n-i-1];
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=n;j++)
			{
				if(ch1[i-1]==ch2[j-1])
					dp[i&1][j]=dp[(i-1)&1][j-1]+1;//用了位運算,也不知道節省的時間多不多=。=
				else
					dp[i&1][j]=max(dp[(i-1)&1][j],dp[i&1][j-1]);
			}
		}
		printf("%d\n",n-dp[n&1][n]);
	}
	return 0;
}


發佈了247 篇原創文章 · 獲贊 5 · 訪問量 7萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章