除法(Division ,UVA 725)-ACM集訓

參考:http://www.cnblogs.com/xiaobaibuhei/p/3301110.html

算法學到很弱,連這麼簡單個問題都難到我了。但我偏不信這個邪,終於做出來了。不過,是參照別人的,是 xiaobaibuhei 到博客讓我找到到感覺,不過我只看了一遍他到代碼,後面都是自己寫的,雖然寫的很像。。。

Write a program that finds and displays all pairs of 5-digit numbers that between them use the digits 0 through 9 once each, such that the first number divided by the second is equal to an integer N, where $2\le N \le 79$. That is,


abcde / fghij = N

where each letter represents a different digit. The first digit of one of the numerals is allowed to be zero.

Input 

Each line of the input file consists of a valid integer N. An input of zero is to terminate the program.

Output 

Your program have to display ALL qualifying pairs of numerals, sorted by increasing numerator (and, of course, denominator).

Your output should be in the following general form:


xxxxx / xxxxx = N

xxxxx / xxxxx = N

.

.


In case there are no pairs of numerals satisfying the condition, you must write ``There are no solutions for N.". Separate the output for two different values of N by a blank line.

Sample Input 

61
62
0

Sample Output 

There are no solutions for 61.

79546 / 01283 = 62
94736 / 01528 = 62


//============================================================================
// Name        : uva 725
// Author      : lvyahui
// Version     :
// Copyright   : Your copyright notice
// Description : Hello World in C++, Ansi-style
//============================================================================

#include <iostream>
#include <cstdio>
#include <list>
#include <cstring>
using namespace std;

char str[10];
bool val[10];

bool check(int a,int b){
	bool isok = true;
	sprintf(str,"%05d%05d",a,b);
	memset(val,false,sizeof(val));
	for (int i = 0; i < 10; ++i) {
		if(val[str[i]-'0']){
			isok = false;break;
                }
		val[str[i]-'0'] = true;
	}
	return isok;
}
int main() {
	int n;


	memset(val,0,sizeof(val));
	scanf("%d",&n);
	int b;
	bool hasans = false;
	for(int a=1234;a < 49383;a++){// b最大到98765 除2就是49383
		// b / a = n
		b = a * n;
		if(b >= 98765){
			break;
		}
		if(check(a,b)){
			printf("%05d / %05d = %d\n",b , a , n);
			if(!hasans){
				hasans = true;
			}
		}
	}
	if(!hasans){
		printf("There are no solutions for %d",n);
	}
	return 0;
}





發佈了35 篇原創文章 · 獲贊 5 · 訪問量 4萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章