ZOJ - 3607 Lazier Salesgirl(模擬)

Lazier Salesgirl

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Kochiya Sanae is a lazy girl who makes and sells bread. She is an expert at bread making and selling. She can sell the i-th customer a piece of bread for price pi. But she is so lazy that she will fall asleep if no customer comes to buy bread for more than w minutes. When she is sleeping, the customer coming to buy bread will leave immediately. It's known that she starts to sell bread now and the i-th customer come after ti minutes. What is the minimum possible value of w that maximizes the average value of the bread sold?

Input

There are multiple test cases. The first line of input is an integer T ≈ 200 indicating the number of test cases.

The first line of each test case contains an integer 1 ≤ n ≤ 1000 indicating the number of customers. The second line contains n integers 1 ≤ pi ≤ 10000. The third line contains nintegers 1 ≤ ti ≤ 100000. The customers are given in the non-decreasing order of ti.

Output

For each test cases, output w and the corresponding average value of sold bread, with six decimal digits.

Sample Input

2
4
1 2 3 4
1 3 6 10
4
4 3 2 1
1 3 6 10

Sample Output

4.000000 2.500000
1.000000 4.000000

題意:有一家麪包店,接下來的第 t[i] 分鐘會有一位客人來以 p[i] 的價格買走一塊麪包,但麪包店只要超過 w 分鐘沒有顧客光臨,老闆就會睡着,
之後來的客人就買不了麪包了,問在保證賣出的麪包的平均價格儘量高的情況下 w 的最小值是多少

思路:由於數據範圍不大,我們只需要暴力枚舉每一個合法的老闆有可能睡着的時間點 t[i] 即可。何謂合法的時間點?即到這一時刻之前 
t[j] - t[j-1]的最大值必定要小於 t[i+1] - t[i]。(保證在這個時間點之前沒睡着,且在下一位客人到來之前睡着)

#include <bits/stdc++.h>
using namespace std;

const int N = 1e4 + 10;
int t, n;
double p[N], v[N], vv[N];
struct xx{
    double p, v;
    int n;
}a[N];

bool cmp(xx a, xx b){
    if(a.p == b.p) return a.v < b.v;
    return a.p > b.p;
}

int main(){
    scanf("%d", &t);
    while(t--){
        scanf("%d", &n);
        double sum = 0, maxi = 0;
        int ii = 0;
        for(int i = 1; i <= n; i++){
            scanf("%lf", &p[i]);
            p[i] += p[i-1];
        }
        for(int i = 1; i <= n; i++){
            scanf("%lf", &v[i]);
            double tmp = v[i]-v[i-1];
            vv[i] = max(vv[i-1], tmp);
        }
        v[n+1] = 0x3f3f3f3f;
        int x = 0;
        for(int i = 1; i <= n; i++){
            if(vv[i] < v[i+1]- v[i]){
                a[x].v = vv[i];
                a[x].p = p[i]/i*1.0;
                x++;
            }
        }
        sort(a, a+x, cmp);
        printf("%.6f %.6f\n", a[0].v, a[0].p);
    }
}


發佈了133 篇原創文章 · 獲贊 5 · 訪問量 3萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章