HDU - 2222 Keywords Search(AC自動機模板題)

Keywords Search

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 67795    Accepted Submission(s): 22825


Problem Description
In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.
 

Input
First line will contain one integer means how many cases will follow by.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.
 

Output
Print how many keywords are contained in the description.
 

Sample Input
1 5 she he say shr her yasherhs
 

Sample Output
3
 

Author
Wiskey
 

Recommend
lcy
 

Statistic | Submit | Discuss | Note
#include <bits/stdc++.h>
using namespace std;

int t, n;
char s[101], f[1000001];
struct xx{
    int cnt;
    xx *fail;
    xx *nex[26];
    xx(){
        memset(nex, NULL, sizeof(nex));
        fail = NULL;
        cnt = 0;
    }
};

void Insert(xx *root, char a[]){
    int l = strlen(a);
    xx *p = root;
    for(int i = 0; i < l; i++){
        int id = a[i]-'a';
        if(p->nex[id] == NULL){
            p->nex[id] = new xx();
        }
        p = p->nex[id];
    }
    (p->cnt)++;
}

void bfs(xx *root){
    queue<xx*> k;
    root->fail = NULL;
    k.push(root);
    xx *p, *tmp;
    while(!k.empty()){
        tmp = k.front();
        k.pop();
        for(int i = 0; i < 26; i++){
            if(tmp->nex[i] != NULL){
                p = tmp->fail;
                while(p && !p->nex[i]){
                    p = p->fail;
                }
                if(!p) tmp->nex[i]->fail = root;
                else tmp->nex[i]->fail = p->nex[i];
                k.push(tmp->nex[i]);
            }
        }
    }
}

int AC_run(xx *root, char a[]){
    int l = strlen(a);
    int ans = 0;
    xx *p = root;
    for(int i = 0; i < l; i++){
        int id = a[i]-'a';
        while(!p->nex[id] && p != root){
            p = p->fail;
        }
        p = p->nex[id];
        if(!p) p = root;
        xx *tmp = p;
        while(tmp != root && tmp->cnt != -1){
            ans += tmp->cnt;
            tmp->cnt = -1;
            tmp = tmp->fail;
        }
    }
    return ans;
}

int main(){
    scanf("%d", &t);
    while(t--){
        scanf("%d", &n);
        xx *root = new xx();
        for(int i = 0; i < n; i++){
            scanf("%s", s);
            Insert(root, s);
        }
        bfs(root);
        scanf("%s", f);
        printf("%d\n", AC_run(root, f));
    }
}


發佈了133 篇原創文章 · 獲贊 5 · 訪問量 3萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章