Photo List(poj3630,Trid字典樹的運用)

Phone List

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 33616   Accepted: 9698

Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:

  • Emergency 911
  • Alice 97 625 999
  • Bob 91 12 54 26

In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output "YES" if the list is consistent, or "NO" otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES

Source

Nordic 2007

 

【解析】

就是Trie字典樹的運用,一開始反應了老半天,原來題目還有個坑點就是如果是前綴的話輸出NO,否則輸出YES。。。。

我說樣例怎麼不太對。

此處需要邊插入邊判斷,如果現在插入的值之前不需要另外加入結點了,那麼說明現在的就是前綴了,如果經過了某個有標記的結點那麼前面就是現在的前綴了。

#include <bits/stdc++.h>
using namespace std;
const int N = 1e4 + 10;
const int Z = 10;

int tot;
int ch[N][Z];
bool bo[N];

void clear()
{
	memset(ch, 0, sizeof(ch));
	memset(bo, 0, sizeof(bo));
}

bool insert(char *s)
{
	int len = strlen(s);
	int u = 1;
	bool flag = 0;
	for (int i = 0; i < len; i++)
	{
		int c = s[i] - '0';
		if (!ch[u][c])
			ch[u][c] = ++tot;
		else if (i == len - 1)
			flag = 0;
		u = ch[u][c];
		if (bo[u])flag = 1;
	}
	bo[u] = 1;
	return flag;
}

int main()
{
	int t;
	scanf("%d", &t);
	while (t--)
	{
		int n;
		scanf("%d", &n);
		tot = 1;
		clear();
		bool ans = 0;
		for (int i = 0; i < n; i++)
		{
			char s[20];
			scanf("%s", s);
			if (insert(s))ans = 1;
		}
		printf("%s\n", ans ? "NO" : "YES");
	}

	return 0;
}

 

發佈了89 篇原創文章 · 獲贊 11 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章