F - Problem F. Grab The Tree (博弈)

Little Q and Little T are playing a game on a tree. There are nn vertices on the tree, labeled by 1,2,...,n1,2,...,n, connected by n−1n−1 bidirectional edges. The ii-th vertex has the value of wiwi. 
In this game, Little Q needs to grab some vertices on the tree. He can select any number of vertices to grab, but he is not allowed to grab both vertices that are adjacent on the tree. That is, if there is an edge between xx and yy, he can't grab both x and y. After Q's move, Little T will grab all of the rest vertices. So when the game finishes, every vertex will be occupied by either Q or T. 
The final score of each player is the bitwise XOR sum of his choosen vertices' value. The one who has the higher score will win the game. It is also possible for the game to end in a draw. Assume they all will play optimally, please write a program to predict the result. 

Input

The first line of the input contains an integer T(1≤T≤20)T(1≤T≤20), denoting the number of test cases. 
In each test case, there is one integer n(1≤n≤100000)n(1≤n≤100000) in the first line, denoting the number of vertices. 
In the next line, there are nn integers w1,w2,...,wn(1≤wi≤109)w1,w2,...,wn(1≤wi≤109), denoting the value of each vertex. 
For the next n−1 lines, each line contains two integers u and v, denoting a bidirectional edge between vertex u and v. 

Output

For each test case, print a single line containing a word, denoting the result. If Q wins, please print Q. If T wins, please print T. And if the game ends in a draw, please print D. 

Sample Input

1
3
2 2 2
1 2
1 3

Sample Output

Q

【解析】

看起來像圖論,但是個幌子。

題意:Q和T博弈,給你n個點,給你n-1條無向邊,Q可以任選點,但是不能選擇相鄰的兩個(即點與點不能有邊相連)。Q選完了T選剩下所有的點。問兩人都選最好的方案(fp,主動權是Q選擇,T只能選所有Q不選的點)。每個點都有權重,然後選完了以後按異或(XOR)相加,看誰結果大。

一波分析以後發現T最好的結果就是平局,不可能獲勝的。

#include <bits/stdc++.h>
using namespace std;
const int maxn = 1e5 + 10;
int main()
{
	int t, n;
	scanf("%d", &t);
	while (t--)
	{
		int w[maxn], u[maxn], v[maxn], flag = 0;
		scanf("%d", &n);
		for (int i = 0; i < n; i++)
			scanf("%d", &w[i]);
		for (int i = 0; i < n-1; i++)
			scanf("%d%d", &u[i], &v[i]);
		for (int j = 0; j < 32; j++)
		{
			int ans = 0;
			for (int i = 0; i < n; i++)
			{
				if (w[i] & 1)ans++;
				w[i] >>= 1;
			}
			if (ans & 1)
			{
				flag = 1;
				break;
			}
		}
		if (flag)printf("Q\n");
		else printf("D\n");
	}
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章