hdu 1492

The number of divisors(約數) about Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2799    Accepted Submission(s): 1362


Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

Now given a humble number, please write a program to calculate the number of divisors about this humble number.For examle, 4 is a humble,and it have 3 divisors(1,2,4);12 have 6 divisors.

 

Input
The input consists of multiple test cases. Each test case consists of one humble number n,and n is in the range of 64-bits signed integer. Input is terminated by a value of zero for n.
 

Output
For each test case, output its divisor number, one line per case.
 

Sample Input
4 12 0
 

Sample Output
3 6
 
剛剛沒看懂...
#include<cstdio>
int a[]={2,3,5,7};
int main()
{
    long long int num;
    int p,ans;
    while(~scanf("%lld",&num))
    {
        ans=1;
        for(int i=0;i<4;i++)
        {
            p=1;long long int num1=num;
            while(num1%a[i]==0&&num1)
            num1/=a[i],p++;
             ans*=p;
        }
      printf("%d\n",ans);
    }
    return 0;
}


發佈了148 篇原創文章 · 獲贊 65 · 訪問量 20萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章