hdu 1018

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 29336    Accepted Submission(s): 13454


Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.
 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

Sample Input
2 10 20
 

Sample Output
7 19
 
ps:公式題
題意:一個數n的階層的位數等於1+log10(i)+.....+log10(n)
#include<cmath>
#include<cstdio>
using namespace std;
int main()
{
    int num,t;
    scanf("%d",&t);
    while(t--)
    {
        double a=1.0;
        scanf("%d",&num);
        for(int i=1;i<=num;i++)
            a+=log10(i);
        printf("%d\n",(int)a);
    }
    return 0;
}


發佈了148 篇原創文章 · 獲贊 65 · 訪問量 20萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章