HDU 1020 Encoding

傳送門 : http://acm.hdu.edu.cn/showproblem.php?pid=1020

Problem Description
Given a string containing only ‘A’ - ‘Z’, we could encode it using the following method:

  1. Each sub-string containing k same characters should be encoded to “kX” where “X” is the only character in this sub-string.

  2. If the length of the sub-string is 1, ‘1’ should be ignored.

Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only ‘A’ - ‘Z’ and the length is less than 10000.

Output
For each test case, output the encoded string in a line.

Sample Input
2
ABC
ABBCCC

Sample Output
ABC
A2B3C

code:

#include<stdio.h>
#include<string.h>
int main()
{
    int t;
    char a[10010];
    scanf("%d",&t);
    getchar();
    while(t--)
    {

        gets(a);
        char ch=a[0];
        int len=strlen(a);
        int cnt=1,i;
        for(i=1;i<len;++i){
            if(ch==a[i])
                ++cnt;
            else
            {
                if(cnt==1) printf("%c",ch);
                else printf("%d%c",cnt,ch);
                ch=a[i];
                cnt=1;
            }
        }
        if(cnt==1) printf("%c",ch);
        else printf("%d%c",cnt,ch);
        printf("\n");
    }
    return 0;
}
發佈了268 篇原創文章 · 獲贊 296 · 訪問量 27萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章