poj1700 Crossing River

Crossing River
Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 12585
Accepted: 4787

Description

A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won't be more than 1000 people and nobody takes more than 100 seconds to cross.

Output

For each test case, print a line containing the total number of seconds required for all the N people to cross the river.

Sample Input

1
4
1 2 5 10

Sample Output

17

Source


題意:n個人一條船,所有人要過河;船每次只能載兩個人,用時按最慢的算;求所有人過河的最小時間。
分析:兩種情況;設最小的和第二小的爲m1,m2,當前
<span style="font-size:18px;">#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a,b) memset(a,b,sizeof(a))
#define MAXN 100010

int T,n;
int a[1010];
int sum;

int main()
{
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        CL(a, 0);
        for(int i=0; i<n; i++)
            scanf("%d",&a[i]);
        if(n == 1){printf("%d\n",a[0]); continue;}
        sort(a, a+n);
        int m1 = a[0], m2 = a[1];
        sum = 0;
        for(int i=n-1; i>1; i-=2)
        {
            if(m2*2<m1+a[i-1])
            {
                if(i == 2) sum = sum+m1+m2+a[i];
                else sum = sum+m1+m2*2+a[i];
            }
            else
            {
                sum = sum+m1*2+a[i]+a[i-1];
                if(i == 2) sum -= a[0];
            }
        }
        if(n!=0&&n%2==0) sum += m2;
        printf("%d\n",sum);
    }
    return 0;
}
</span>

最大的和第二大的爲n1,n2;
1、m2+m2<m1+n2;m1和m2先過河,然後m1回來,n1和n2過河,m2回來;
2、m2+m2>m1+n2;m1和n1先過河,然後m1回來,m1和n2過河,m1回來;
另外還要注意奇數的情況。


發佈了159 篇原創文章 · 獲贊 8 · 訪問量 21萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章