HDU5437 Alisha’s Party(優先隊列+模擬)

Alisha’s Party

Time Limit: 3000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 4075    Accepted Submission(s): 1052


Problem Description
Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value v, and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first.

Each time when Alisha opens the door, she can decide to let p people enter her castle. If there are less than p people in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.

If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query n Please tell Alisha who the nth person to enter her castle is.
 

Input
The first line of the input gives the number of test cases, T , where 1T15.

In each test case, the first line contains three numbers k,m and q separated by blanks. k is the number of her friends invited where 1k150,000. The door would open m times before all Alisha’s friends arrive where 0mk. Alisha will have q queries where 1q100.

The ith of the following k lines gives a string Bi, which consists of no more than 200 English characters, and an integer vi, 1vi108, separated by a blank. Bi is the name of the ith person coming to Alisha’s party and Bi brings a gift of value vi.

Each of the following m lines contains two integers t(1tk) and p(0pk) separated by a blank. The door will open right after the tth person arrives, and Alisha will let p friends enter her castle.

The last line of each test case will contain q numbers n1,...,nq separated by a space, which means Alisha wants to know who are the n1th,...,nqth friends to enter her castle.

Note: there will be at most two test cases containing n>10000.
 

Output
For each test case, output the corresponding name of Alisha’s query, separated by a space.
 

Sample Input
1 5 2 3 Sorey 3 Rose 3 Maltran 3 Lailah 5 Mikleo 6 1 1 4 2 1 2 3
 

Sample Output
Sorey Lailah Rose
 

Source

題意:有k個人帶着價值vi的禮物來,開m次門,每次在有t個人來的時候開門放進來p個人,所有人都來了之後再開一次門把剩下的人都放進來,每次帶禮物價值高的人先進,價值相同先來先進,q次詢問,詢問第n個進來的人的名字。

分析:優先隊列+模擬就可以了,只是注意m可以爲0。

<span style="font-size:18px;">#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a,b) memset(a,b,sizeof(a))
#define lson (i<<1)
#define rson ((i<<1)|1)
#define MAXN 150010

struct node
{
    int id,v;
    char name[220];
    bool operator < (const node &tmp) const
    {
        if(v == tmp.v) return id < tmp.id;
        return v > tmp.v;
    }
}p[MAXN];

struct opendoor
{
    int a,b;
    bool operator < (const opendoor &tmp) const
    {
        return a < tmp.a;
    }
}od[MAXN];

set<node> s;
int query[110];

int main()
{
    int T,n,m,q;
    scanf("%d",&T);
    while(T--)
    {
        s.clear();
        scanf("%d%d%d",&n,&m,&q);
        for(int i=1; i<=n; i++)
        {
            scanf("%s %d",p[i].name, &p[i].v);
            p[i].id = i;
        }
        for(int i=0; i<m; i++)
            scanf("%d%d",&od[i].a, &od[i].b);
        sort(od, od+m);
        int maxq;
        for(int i=0; i<q; i++)
        {
            scanf("%d",&query[i]);
            maxq = max(maxq, query[i]);
        }
        vector <int> ans;
        int cnt = 0;
        for(int i=1; i<=n&&ans.size()<maxq; i++)
        {
            s.insert(p[i]);
            while(od[cnt].a==i && cnt<m)
            {
                for(int j=0; j<od[cnt].b&&!s.empty()&&ans.size()<maxq; j++)
                {
                    ans.push_back(s.begin()->id);
                    s.erase(s.begin());
                }
                cnt++;
            }
        }
        while(!s.empty() && ans.size()<maxq)
        {
            ans.push_back(s.begin()->id);
            s.erase(s.begin());
        }
        for(int i=0; i<q; i++)
        {
            if(i) printf(" ");
            cout<<p[ans[query[i]-1]].name;
        }
        puts("");
    }
    return 0;
}
</span>


發佈了159 篇原創文章 · 獲贊 8 · 訪問量 21萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章