Wall Painting

Wall Painting
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2557 Accepted Submission(s): 814

Problem Description
Ms.Fang loves painting very much. She paints GFW(Great Funny Wall) every day. Every day before painting, she produces a wonderful color of pigments by mixing water and some bags of pigments. On the K-th day, she will select K specific bags of pigments and mix them to get a color of pigments which she will use that day. When she mixes a bag of pigments with color A and a bag of pigments with color B, she will get pigments with color A xor B.
When she mixes two bags of pigments with the same color, she will get color zero for some strange reasons. Now, her husband Mr.Fang has no idea about which K bags of pigments Ms.Fang will select on the K-th day. He wonders the sum of the colors Ms.Fang will get with different plans.

For example, assume n = 3, K = 2 and three bags of pigments with color 2, 1, 2. She can get color 3, 3, 0 with 3 different plans. In this instance, the answer Mr.Fang wants to get on the second day is 3 + 3 + 0 = 6.
Mr.Fang is so busy that he doesn’t want to spend too much time on it. Can you help him?
You should tell Mr.Fang the answer from the first day to the n-th day.

Input
There are several test cases, please process till EOF.
For each test case, the first line contains a single integer N(1 <= N <= 103).The second line contains N integers. The i-th integer represents the color of the pigments in the i-th bag.

Output
For each test case, output N integers in a line representing the answers(mod 106 +3) from the first day to the n-th day.

Sample Input
4
1 2 10 1

Sample Output
14 36 30 8

Source
2013ACM/ICPC亞洲區南京站現場賽——題目重現

wa了無數遍 ~~ 只是因爲取餘沒有掌握好QAQ
題意是讓求好多n個數裏面挑1-n個數的異或和
計算每一位做的貢獻就好了
改了無數遍湊活看O_O 沒有打註釋

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <queue>
#include <stack>

using namespace std;
typedef long long LL;
const int mod=1000003;
int n;
LL num[1150];
LL ans[1150];
LL f[1150][1150];
bool cmp(int a,int b)
{
    return a>b;
}
void init()
{
    memset(f,0,sizeof(f));
    for(int i=0;i<1150;i++)
        f[i][0]=f[i][i]=1;
    for(int i=1;i<1150;i++)
        for(int j=1;j<i;j++)
            f[i][j] = (f[i-1][j]+f[i-1][j-1])%mod;
}
int main(){
    init();
    while(~scanf("%d",&n)){
        memset(ans,0,sizeof(ans));
        memset(num,0,sizeof(num));
        for(int i=1;i<=n;i++)
            scanf("%lld",&num[i]);
        sort(num+1,num+n+1,cmp);
        LL ml=1;
        while(num[1]){
            LL cnt1=0;
            for(int i=1;i<=n;i++){
                if(!num[i])
                    break;
                if(num[i]&1)
                    cnt1++;
                num[i]>>=1;
            }
            for(int i=1;i<=n;i++){
                LL cnt=0;
                for(int j=1;j<=i;j+=2){
                      cnt+=f[cnt1][j]*f[n-cnt1][i-j]%mod;
                }
                cnt=cnt*ml%mod;
                ans[i]=(ans[i]+cnt)%mod;
            }
            ml=ml*2%mod;
        }
        for(int i=1;i<n;i++)
            printf("%lld ",ans[i]);
        printf("%lld\n",ans[n]);
    }
    return 0;
}
發佈了95 篇原創文章 · 獲贊 0 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章