HD 1003 Max Sum(貪心)


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
Case 1: 14 1 4 Case 2: 7 1 6
 

思路:對於每一個當前點都保證相加之後的和比本身大就好了,貪心思想。如果用我註釋掉的方法做超時,但目前還沒想到怎麼優化,歡迎評論|“_”|


代碼如下:

#include<iostream>
#include<stdio.h>
#define M 100000+5
#define LL long long
using namespace std;

//int a[M];

int main(){
	int t,ans=0; 
	while(scanf("%d", &t)!=EOF){
		while(t--){
			int n,st=1,ed=1,est=1;
			int sum,x,maxn;
			scanf("%d%d", &n, &x);
			sum=maxn=x;
			for(int i=2; i<=n; ++i){
				scanf("%d", &x);
				if(sum+x<x){
					sum=x;
					st=i;
				}
				else{
					sum+=x;
				}
				if(maxn<sum){
					maxn=sum;
					est=st;
					ed=i;
				}
			}
			
			/*for(int i=1; i<=n; ++i){//超時 
				if(a[i]<=0)	continue;
				for(int j=i,k; j<=n ; ++j){
					//int k;
					s=0;
					for(k=1; k<=j; ++k){
						s+=a[k];
						if(sum<s){
							sum=s;
							st=i;
							ed=k;
						}	
					}		
				}
			}*/ 
			if(ans!=0)	printf("\n");
			printf("Case %d:\n%d %d %d\n",++ans, maxn, est, ed);
		}
	}
	return 0;
}



發佈了89 篇原創文章 · 獲贊 72 · 訪問量 12萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章