poj 2155 - Matrix(二維樹狀數組)


Matrix
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 25606   Accepted: 9478

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1



#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define lowbit(x) (x&-x)
const int maxn = 1030;
int sum[maxn][maxn];
int n;

void add(int x, int y, int val)
{
	for (int i = x; i <= n; i += lowbit(i))
	{
		for (int j = y; j <= n; j += lowbit(j))
		{
			sum[i][j] += val;
		}
	}
}

int query(int x, int y)
{
	int ret = 0;
	for (int i = x; i; i -= lowbit(i))
	{
		for (int j = y; j; j -= lowbit(j))
		{
			ret += sum[i][j];
		}
	}
	return ret;
}

int main()
{
	int T, q;
	scanf("%d", &T);
	while (T--)
	{
		scanf("%d%d", &n, &q);
		n++;
		memset(sum, 0, sizeof(sum));
		char index[10];
		while (q--)
		{
			scanf("%s", index);
			int x1, y1, x2, y2;
			if (index[0] == 'Q')
			{
				scanf("%d%d", &x1, &y1);
				if (query(x1, y1) % 2)
					puts("1");
				else
					puts("0");
			}
			else if (index[0] == 'C')
			{
				scanf("%d%d%d%d", &x1, &y1, &x2, &y2);
				add(x1, y1, 1);
				add(x1, y2 + 1, 1);
				add(x2 + 1, y1, 1);
				add(x2 + 1, y2 + 1, 1);
			}
		}
		if (T)
			puts("");
	}
	return 0;
}


發佈了72 篇原創文章 · 獲贊 4 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章