POJ 1905 - Expanding Rods(二分查找)

Description

When a thin rod of length L is heated n degrees, it expands to a new length L’=(1+n*C)*L, where C is the coefficient of heat expansion.
When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment.

Your task is to compute the distance by which the center of the rod is displaced.


Input

The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.

Output

For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision.

Sample Input

1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1

Sample Output

61.329
225.020
0.000


Solution

題目大意:長爲L的一個竿子,受熱後會向上彎曲彎曲後的長度爲L=(1+nC)L ,求竿子可以向上彎曲的最大值hLL/2.
L 看作一個半徑爲R ,圓心角爲2a 的圓的弧長。則L 爲該圓的弦長。
可以得到如下公式:

R2=(Rh)2+(L/2)2sina=L/2RRa=L/2

剛開始我想通過弧微分把弧長表示出來,然後進行二分。應該是精度出現問題,所以一直過不了。代碼在最後!!!


AC Code

#include <stdio.h>
#include <string.h>
#include <math.h>
#define eps 1e-5


int main() 
{
    double L, n, C;
    while (~scanf("%lf%lf%lf",&L,&n,&C)&&L!=-1&&n!=-1&&C!=-1)
    {

        double L1 = (1 + n*C)*L;
        double l = 0, r = L / 2, h;
        while (r-l>eps)
        {
            h = (l + r) / 2;
            double R = ((L*L / 4 + h*h) / (2 * h));
            double a = asin(L / (2 * R));
            if (R*a >= L1 / 2) r = h;
            else l = h;

        }
        printf("%.3f\n", h);
    }
}

WA Code

#include <stdio.h>
#include <string.h>
#include<math.h>
#define eps 1e-10
int L, n;
double C;
double L1, L2, a, c, al;
double lo;
int judge(double L2, double L1)
{
    if (L2 > L1) return 1;
    else return 0;
}
int main()
{
    while (~scanf_s("%d%d%lf", &L, &n, &C) && L != -1 && n != -1 && C != -1) {

        double r = L/2;
        double l = 0;
        double ans;

        while (r-l>eps)
        {

            c = (l + r) / 2;
            al = (-4 * c) / L;
            a = (-4 * c) / (L * L);
            lo = logl(al + sqrtl((double)(1 + al*al)));
            L2 = (al*sqrtl((double)(1 + al*al)) + lo) / (2 * a);
            L1 = (1 + n*C)*L;
            if (judge(L2, L1))  r = c;
            else l = c,ans=c;
        }
        printf("%.3f\n", ans);





    }
    return 0;
}
發佈了77 篇原創文章 · 獲贊 47 · 訪問量 20萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章