POJ 2431 - Expedition (貪心 優先隊列)

Description

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck’s fuel tank. The truck now leaks one unit of fuel every unit of distance it travels.

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop).

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000).

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all.

Input

  • Line 1: A single integer, N

  • Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop.

  • Line N+2: Two space-separated integers, L and P

Output

  • Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2


Solution

題目大意:一輛車要去終點,車輛初始油量爲P,距離終點距離爲L,路上有n個加油站,每個加油站的加油量都不同。求這輛車到終點最少加多少次油?
解題思路:按照距離終點的距離,進行升序排序。將當前油量可以到達的加油站都放進優先隊列,如果P>L,則不加油,否則從優先隊列裏面選擇油量最多的加油站加油即可。

優先隊列可以參考另外一個博主的文章
C++(標準庫)棧和隊列以及優先隊列的使用


Code

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <iostream>
#include <algorithm>
#include <queue>
using namespace std;
#define N 10010
struct cmp
{
    int l, cnt;
    bool operator <(const cmp&b)const
    {
        return l > b.l;
    }
}a[N];
int n, L, P;
priority_queue<int>que;
int main() {
    while (~scanf("%d",&n))
    {
        for (int i = 0; i < n; i++)
            scanf("%d%d", &a[i].l, &a[i].cnt);
        scanf("%d%d", &L, &P);
        if (P >= L) printf("0");
        else
        {
            sort(a, a + n);
            while (!que.empty()) que.pop();
            int i = 0, now = P, ans = 0;
            while (i < n&&L - P <= a[i].l) que.push(a[i++].cnt); //車可以到達a[i]加油站
            while (!que.empty())
            {
                now += que.top();
                que.pop();
                ans++;
                if (now >= L) break;
                while (i < n&&L - now <= a[i].l) que.push(a[i++].cnt);

            }
            if (now >= L) printf("%d\n", ans);
            else printf("-1\n");

        }

    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章