POJ1862 水

Stripies

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 18021 Accepted: 8109

Description

Our chemical biologists have invented a new very useful form of life called stripies (in fact, they were first called in Russian - polosatiki, but the scientists had to invent an English name to apply for an international patent). The stripies are transparent amorphous amebiform creatures that live in flat colonies in a jelly-like nutrient medium. Most of the time the stripies are moving. When two of them collide a new stripie appears instead of them. Long observations made by our scientists enabled them to establish that the weight of the new stripie isn’t equal to the sum of weights of two disappeared stripies that collided; nevertheless, they soon learned that when two stripies of weights m1 and m2 collide the weight of resulting stripie equals to 2*sqrt(m1*m2). Our chemical biologists are very anxious to know to what limits can decrease the total weight of a given colony of stripies.
You are to write a program that will help them to answer this question. You may assume that 3 or more stipies never collide together.

Input

The first line of the input contains one integer N (1 <= N <= 100) - the number of stripies in a colony. Each of next N lines contains one integer ranging from 1 to 10000 - the weight of the corresponding stripie.

Output

The output must contain one line with the minimal possible total weight of colony with the accuracy of three decimal digits after the point.

Sample Input

3
72
30
50

Sample Output

120.000

Thinking:每次取優先隊列中最大的兩個數進行計算,直到計算出結果。

a > c(前提 a >= b >= c >= 0)
-> c^2 * a * b > a^2 * b * c
-> c * sqrt(a * b) > a * sqrt(b * c)
-> 2 * sqrt(2 * c * sqrt(a * b)) > 2 * sqrt(2 * a * sqrt(b * c))

#include<iostream>
#include<queue>
#include<cmath>
using namespace std;

int N;
priority_queue<double> pq;
int main(){
    while(scanf("%d", &N) == 1 && N){
        double wei = 0.0;
        for(int i = 0; i < N; i++){
            scanf("%lf", &wei);
            pq.push(wei);
        }
        while(pq.size() > 1){
            double x = pq.top(); pq.pop();
            double y = pq.top(); pq.pop();
            pq.push(2*sqrt(x*y));
        }
        printf("%.3f\n", pq.top());
        pq.pop();
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章