POJ 3176

Cow Bowling

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20173 Accepted: 13372

Description

The cows don’t use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this:

      7



    3   8



  8   1   0



2   7   4   4

4 5 2 6 5
Then the other cows traverse the triangle starting from its tip and moving “down” to one of the two diagonally adjacent cows until the “bottom” row is reached. The cow’s score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame.

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

Output

Line 1: The largest sum achievable using the traversal rules

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

Thinking 簡單dp 我食言了 4天才做了一道題,誰來挽救我的Java

#include<cstdio>
#include<algorithm>
using namespace std;

const int maxn = 352;
int N;
int map[maxn][maxn];
int dp[maxn][maxn];

void solve()
{
    dp[0][0] = map[0][0];
    for(int i = 1; i < N; i++)
        for(int j = 0; j <= i; j++){
            if(j == 0) dp[i][j] = max(map[i][j], map[i][j] + dp[i-1][j]);
            else if( j == i) dp[i][j] = max(map[i][j], map[i][j] + dp[i-1][j-1]);
            else dp[i][j] = max(map[i][j]+dp[i-1][j-1], map[i][j]+dp[i-1][j]);
        }

    int res = 0;
    for(int i = 0; i < N; i++)
        res = max(res, dp[N-1][i]);
    printf("%d\n", res);
}

int main(){
    scanf("%d", &N);
    for(int i = 0; i < N; i++)
        for(int j = 0; j <= i; j++)
            scanf("%d", &map[i][j]);
    solve();
    return 0;
}
發佈了38 篇原創文章 · 獲贊 11 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章