POJ 1163 The Triangle

Description

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally( 對角線地 ) down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

Thinking :

#include<cstdio>
#include<vector>
#include<iostream>
#include<cstring>
using namespace std;

vector<int> v1, v2;
int N;
const int maxn = 100+5;
int maxx = -100000; //最長路徑長度
int m[maxn][maxn]; //輸入每個節點值
int dp[maxn][maxn]; //每個節點到頂點的最大值

int max(int i, int j){
    return i>j?i:j;
}

int maxtotal(int i, int j){
    if(i == N) return 0;
    if(dp[i][j] >= 0) return dp[i][j];
    return dp[i][j] = m[i][j] + max(maxtotal(i+1, j), maxtotal(i+1, j+1));
}

int main(){
    scanf("%d", &N);
    memset(dp, -1, sizeof(dp));
    for(int i = 0; i < N; i++)
        for(int j = 0; j <= i; j++)
            scanf("%d", &m[i][j]);
    printf("%d", maxtotal(0, 0));
    return 0;
}
發佈了38 篇原創文章 · 獲贊 11 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章