POJ 3262

Protecting the Flowers

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 8037 Accepted: 3247

Description

Farmer John went to cut some wood and left N (2 ≤ N ≤ 100,000) cows eating the grass, as usual. When he returned, he found to his horror that the cluster of cows was in his garden eating his beautiful flowers. Wanting to minimize the subsequent damage, FJ decided to take immediate action and transport each cow back to its own barn.

Each cow i is at a location that is Ti minutes (1 ≤ Ti ≤ 2,000,000) away from its own barn. Furthermore, while waiting for transport, she destroys Di (1 ≤ Di ≤ 100) flowers per minute. No matter how hard he tries, FJ can only transport one cow at a time back to her barn. Moving cow i to its barn requires 2 × Ti minutes (Ti to get there and Ti to return). FJ starts at the flower patch, transports the cow to its barn, and then walks back to the flowers, taking no extra time to get to the next cow that needs transport.

Write a program to determine the order in which FJ should pick up the cows so that the total number of flowers destroyed is minimized.

Input

Line 1: A single integer N
Lines 2..N+1: Each line contains two space-separated integers, Ti and Di, that describe a single cow’s characteristics

Output

Line 1: A single integer that is the minimum number of destroyed flowers

Sample Input

6
3 1
2 5
2 3
3 2
4 1
1 6

Sample Output

86

Thinking: 這回貪心假設有兩頭牛(a, b) , (x, y)(T爲這兩頭牛被趕之前的時間)

(a, b)先的話被吃的草爲 Tb + (T + a)y ①
(x, y)先的話被吃的草爲 Ty + (T + x)b ②
① - ② 得到 ay - xb
排序按 ay < xb 取值即可

#include<cstdio>
#include<algorithm>
using namespace std;

int N;
const int maxn = 100005;
struct node {
    int T, D;
    bool operator < (const node& n) const {
        return T*n.D < n.T*D;
    }
}cows[maxn];

void solve() {
    sort(cows, cows + N);
    long long res = 0;
    for (int i = 0; i < N; i++)
        res += (long long)cows[i].D;
    long long ans = 0;
    for (int i = 0; i < N; i++) {
        res -= (long long)cows[i].D;
        ans += res * cows[i].T * 2;
    }
    printf("%lld\n", ans);
}

int main() {
    scanf("%d", &N);
    for (int i = 0; i < N; i++)
        scanf("%d%d", &cows[i].T, &cows[i].D);
    solve();
    return 0;
}
發佈了38 篇原創文章 · 獲贊 11 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章