算法學習【14】—— 1190. Reduced ID Numbers

題目來源:http://soj.me/1190

1190. Reduced ID Numbers

Constraints

Time Limit: 2 secs, Memory Limit: 32 MB

Description

T. Chur teaches various groups of students at university U. Every U-student has a unique Student Identification Number (SIN). A SIN s is an integer in the range 0 ≤ s ≤ MaxSIN with MaxSIN = 106-1. T. Chur finds this range of SINs too large for identification within her groups. For each group, she wants to find the smallest positive integer m, such that within the group all SINs reduced modulo m are unique.

Input

On the first line of the input is a single positive integer N, telling the number of test cases (groups) to follow. Each case starts with one line containing the integer G (1 ≤ G ≤ 300): the number of students in the group. The following G lines each contain one SIN. The SINs within a group are distinct, though not necessarily sorted.

Output

For each test case, output one line containing the smallest modulus m, such that all SINs reduced modulo m are distinct.

Sample Input

2
1
124866
3
124866
111111
987651

Sample Output

1
8

思路:

這個看懂題目應該就OK的了,太久沒敲代碼,結果WA了一次student數組沒有剩餘。暴力搜索吧。

代碼:

/*
Problem link: http://soj.me/1190
Author: BetaBin
Date: 2012/07/25
*/
#include <stdio.h>
#include <memory.h>

int students[302];
bool buckets[1000000];
int studentNum;
int groupNum;
int answer;

bool Test(int target)
{
    int remainder;
    memset(buckets, false, sizeof(bool) * answer);
    for(int i = 0; i < studentNum; ++i)
    {
        remainder = students[i] % target;
        if(buckets[remainder])
        {
            return false;
        }
        else
        {
            buckets[remainder] = true;
        }
    }
    return true;
}

int main()
{
    scanf("%d", &groupNum);
    while(groupNum--)
    {
        scanf("%d", &studentNum);
        for(answer = 0; answer < studentNum; ++answer)
        {
            scanf("%d", &students[answer]);
        }
        while(!Test(answer))
        {
            ++answer;
        }
        printf("%d\n", answer);
    }
    return 0;
}


發佈了121 篇原創文章 · 獲贊 9 · 訪問量 61萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章