Sicily 13290 Play with Strings powered by wangbin

13290. Play with Strings

Constraints

Time Limit: 1 secs, Memory Limit: 256 MB

Description

Given a string X, you can swap any two characters in X as many times as you want. You wonder whether it is possible to turn X into another string Y.

Input

The input consists of two lines. The first line is X, and the second line is YX and Y only contain lower-case letters. No strings contain more than 100 letters.

Output

For each test case, output “YES” if you can turn X into Y; otherwise, output “NO”.

Sample Input

abceecba

Sample Output

YES
#include<iostream>
#include<string>
#include<cstring>
using namespace std;
int main(){
	string s1,s2;
	cin>>s1;
	cin>>s2;
	int sum1=0,sum2=0;
	int len1=s1.size();
	int len2=s2.size();
	for(int i=0; i<=len1; i++){
		sum1+=s1[i]; 
	}
	for(int i=0; i<=len2; i++){
		sum2+=s2[i]; 
	}
	if(sum1==sum2)
		cout<<"YES"<<endl;
	else 
		cout<<"NO"<<endl;
	return 0;
} 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章