算法學習【16】—— 1119. Factstone Benchmark

題目來源:http://soj.me/1119

1119. Factstone Benchmark

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

Amtel has announced that it will release a 128-bit computer chip by 2010, a 256-bit computer by 2020, and so on, continuing its strategy of doubling the word-size every ten years. (Amtel released a 64-bit computer in 2000, a 32-bit computer in 1990, a 16-bit computer in 1980, an 8-bit computer in 1970, and a 4-bit computer, its first, in 1960.)

Amtel will use a new benchmark - the Factstone - to advertise the vastly improved capacity of its new chips. The Factstone rating is defined to be the largest integer n such that n! can be represented as an unsigned integer in a computer word.

Input

Given a year 1960 ≤ y ≤ 2160, what will be the Factstone rating of Amtel's most recently released chip?

Output

There are several test cases. For each test case, there is one line of input containing y. A line containing 0 follows the last test case. For each test case, output a line giving the Factstone rating.

Sample Input

1960
1981
0

Sample Output

3
8

思路:繼續水題,這裏題目抽象爲求最大的n,能符合n! <= 2^bits,其中bits = 2 ^ ((year - 1996) / 10 + 2)。直接階乘會溢出,用log中轉下。因爲有log(n*m) = log(n) + log(m)。然後就變成累加log(n) / log(2),使之大於bits了。(敲代碼的時候犯了個小錯誤,沒有考慮到log(n) / log(2)是個小數,囧。)

代碼:

/*
Link:
Author: BetaBin http://soj.me/1119
Date: 2012/07/26
*/
/*
#include <stdio.h>

int main()
{
    int year;
    int answer[21] = {3,5,8,12,20,34,57,98,170,300,536,966,1754,3210,5910,10944,20366,38064,71421,134480,254016};
    while(scanf("%d", &year) && year)
    {
        printf("%d\n", answer[(year - 1960) / 10]);
    }
    return 0;
}
*/

#include <stdio.h>
#include <math.h>

//原來的錯誤,忽略了在相等情況下,小數的影響,取1960分析可得錯誤
//需要用double,而不應該是int

int main()
{
    int year;
    int endflag;
    int n;
    double sum;
    while(scanf("%d", &year) && year)
    {
        endflag = pow(2, (year - 1960) / 10 + 2);
        n = 2;
        sum = 0;

        while(sum <= endflag)
        {
            sum += log(n) / log(2);
            ++n;
        }
        printf("%d\n", n - 2);
    }
    return 0;
}


發佈了121 篇原創文章 · 獲贊 9 · 訪問量 61萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章