hdu 2955

Description

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
 

Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 

Sample Input

3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
 

Sample Output

2 4 6
題意:
輸入一個數,表示一共有多少組數據,輸入一個浮點型數據表示被小偷被抓的機率不超過這個的情況下能頭的最多錢,輸入一個整型表示銀行數,求小偷在不被抓的情況下頭的最多錢。
思路:
揹包;第一次做的時候把概率當做揹包(放大100000倍化爲整數):在此範圍內最多能搶多少錢  最腦殘的是把總的概率以爲是搶N家銀行的概率之和… 把狀態轉移方程寫成了f[j]=max{f[j],f[j-q[i].v]+q[i].money}(f[j]表示在概率j之下能搶的大洋); 正確的方程是:f[j]=max(f[j],f[j-q[i].money]*q[i].v)  其中,f[j]表示搶j塊大洋的最大的逃脫概率,條件是f[j-q[i].money]可達,也就是之前搶劫過始化爲:f[0]=1,其餘初始化爲-1  (0塊大洋肯定不被抓嘛)
代碼:
#include<cstdio>
#include<cstring>
#include<algorithm>
int m[1000];//銀行裏的錢
double pp[1000];//搶劫銀行被抓的概率
double dp[10000];
using namespace std;
int main()
{
    int T,N;
    double P;
    scanf("%d",&T);
    while(T--)
    {
        int sum=0;
        scanf("%lf%d",&P,&N);
        for(int i=0; i<N; i++)
        {
            scanf("%d%lf",&m[i],&pp[i]);
            sum+=m[i];
        }
        memset(dp,0,sizeof(dp));
        dp[0]=1;//搶劫銀行0元錢不被抓的概率爲1
        for(int i=0; i<N; i++)
            for(int j=sum; j>=m[i]; j--)
                dp[j]=max(dp[j],dp[j-m[i]]*(1-pp[i]));
                          for(int i=sum; i>=0; i--)
            {
                if(dp[i]>=1-P)
                {
                    printf("%d\n",i);
                    break;
                }

            }

    }
    return 0;
}


  

發佈了76 篇原創文章 · 獲贊 7 · 訪問量 4萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章