hdu 4956 Poor Hanamichi(BC.R#5) 讀懂了題意就是水題/坑- -比賽中居然沒有過



Poor Hanamichi

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 175    Accepted Submission(s): 86


Problem Description
Hanamichi is taking part in a programming contest, and he is assigned to solve a special problem as follow: Given a range [l, r] (including l and r), find out how many numbers in this range have the property: the sum of its odd digits is smaller than the sum of its even digits and the difference is 3.

A integer X can be represented in decimal as:
\(X = A_n\times10^n + A_{n-1}\times10^{n-1} + \ldots + A_2\times10^2 + A_1\times10^1 + A_0\)
The odd dights are \(A_1, A_3, A_5 \ldots\) and \(A_0, A_2, A_4 \ldots\) are even digits.

Hanamichi comes up with a solution, He notices that:
\(10^{2k+1}\) mod 11 = -1 (or 10), \(10^{2k}\) mod 11 = 1,
So X mod 11
= \((A_n\times10^n + A_{n-1}\times10^{n-1} + \ldots + A_2\times10^2 + A_1\times10^1 + A_0) \mod 11\)
= \(A_n\times(-1)^n + A_{n-1}\times(-1)^{n-1} + \ldots + A_2 - A_1 + A_0\)
= sum_of_even_digits – sum_of_odd_digits
So he claimed that the answer is the number of numbers X in the range which satisfy the function: X mod 11 = 3. He calculate the answer in this way :
Answer = (r + 8) / 11 – (l – 1 + 8) / 11.

Rukaw heard of Hanamichi’s solution from you and he proved there is something wrong with Hanamichi’s solution. So he decided to change the test data so that Hanamichi’s solution can not pass any single test. And he asks you to do that for him.
 

Input
You are given a integer T (1 ≤ T ≤ 100), which tells how many single tests the final test data has. And for the following T lines, each line contains two integers l and r, which are the original test data. (1 ≤ l ≤ r ≤ \(10^{18}\))
 

Output
You are only allowed to change the value of r to a integer R which is not greater than the original r (and R ≥ l should be satisfied) and make Hanamichi’s solution fails this test data. If you can do that, output a single number each line, which is the smallest R you find. If not, just output -1 instead.
 

Sample Input
3 3 4 2 50 7 83
 

Sample Output
-1 -1 80
 

Source
 

題目大意:
有一個人在用一種方法來計算給定閉區間【l,r】內所有符合“奇數位的數之和比偶數位的數之和小三”的條件的數的個數。
關於奇數偶數位的說明
X=An×10n+An1×10n1++A2×102+A1×101+A0
The odd dights are A1,A3,A5 and A0,A2,A4 are even digits.

關於計算公式:
segma( A0,A2,A4…)-segma( A1,A3,A5)=3         (*1)

這個人的那種方法是
So X mod 11
= (An×10n+An1×10n1++A2×102+A1×101+A0)mod11
= An×(1)n+An1×(1)n1++A2A1+A0
= sum_of_even_digits – sum_of_odd_digits =3 (*2)

這個人認爲對於一個數x,只要x mod 11==3,那麼他就是符合條件的。

現在要求你找出新的最小的右端點r來改變區間範圍,使得這個人的結論不成立。



解題思路:
這道題的意思極盡曲折,總的意思就是找出最小的一個數,這個數恰可以使得(*2)成立,而(*1)不成立
也就是x mod 11==3但是(*1)不成立,這就是解題的關鍵了,把題意理解好就枚舉就好了。


下面是ac代碼:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#define maxn 160
using namespace std;
typedef unsigned __int64 LL;
LL l,r;
int main()
{
    int T;
    LL i,j,y=0;
    scanf("%d",&T);
    while(T--){
        scanf("%I64u %I64u",&l,&r);
        bool flag=false;
        for(i=l;i<=r;i+=1){
            if(i%11==3){
                y=i;
                LL res=0,ans=0;
                for(j=0;y>0;j++){
                    LL x=y%10;
                    y/=10;
                    if(j&1)res+=x;
                    else ans+=x;
                }
        //printf("%I64d %I64d %I64d\n",i,res,ans);
                if(res!=ans-3){
                    printf("%I64u\n",i);
                    flag=true;
                    break;
                }
            }
        }
        if(!flag) printf("-1\n");
    }
    return 0;
}


 
發佈了91 篇原創文章 · 獲贊 0 · 訪問量 3萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章