(有坑可複習)poj 1083 Moving Tables 模擬/貪心/技巧性質

Moving Tables
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 25839   Accepted: 8600

Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager's problem.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables to move.
Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd
line, the remaining test cases are listed in the same manner as above.

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input

3 
4 
10 20 
30 40 
50 60 
70 80 
2 
1 3 
2 200 
3 
10 100 
20 80 
30 50 

Sample Output

10
20
30


題目大意:

四百個房間,兩排,每排兩百個。現要在房間間搬桌子,任意房間間搬桌子的時間都是十分鐘。

且每個房間只會要麼搬出要麼搬進,具有重疊部分的兩次搬運不可同時進行(閉區間)。

要求最小搬運次數。


解題思路:

法一, 可以先按照左端點升序排序,每次掃一遍,將所有可以同時進行的搬運一次處理完(這裏是用結構體內的used標記),最後計算總次數即可。

法二,直接找出被區間覆蓋最多的那個點的覆蓋次數就是答案 - -這個方法沒做

本題需要注意兩個問題:坑~!!!!

第一,一號房和二號房是不能同時搬運的,所以可以在輸入時將奇數變爲偶數。

第二,要注意給的數據不一定是前小後大,所以如果前大後小就需要交換一下



下面是ac代碼:

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#include <memory>
#include <string>
#include <vector>
#include <list>
#include <map>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <numeric>
#include <functional>
#define maxn 205
#define mod 100007

using namespace std;
struct M{
    bool used;
    int l;
    int r;
    M(){
        used=false;
    }
};

bool comp(const M &a,const M &b)
{
    return a.l<b.l;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        int n;
        M mov[maxn];
        scanf("%d",&n);
        for(int i=0;i<n;i+=1){
            int a,b;
            scanf("%d %d",&a,&b);
            if(a>b) swap(a,b);
            if(a%2!=0) a+=1;
            if(b%2!=0) b+=1;
            mov[i].l=a;
            mov[i].r=b;
        }
        sort(mov,mov+n,comp);

        /*for(int i=0;i<n;i+=1){
            printf("%d %d\n",mov[i].l,mov[i].r);

        }*/

        int countt=0;
        bool flag=true;
        while(flag){
            int next=-1;
            flag=false;
            for(int i=0;i<n;i+=1){
                if(!(mov[i].used)&&next<mov[i].l){
                    next=mov[i].r;
                    mov[i].used=true;
                    flag=true;
                }
            }
            countt+=1;
        }

        printf("%d\n",(countt-1)*10);
    }

    return 0;
}




發佈了91 篇原創文章 · 獲贊 0 · 訪問量 3萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章