hdu 2147 kiki's game 博弈

點擊打開鏈接鏈接

kiki's game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 40000/1000 K (Java/Others)
Total Submission(s): 6933    Accepted Submission(s): 4141


Problem Description
Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?
 

Input
Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.

 

Output
If kiki wins the game printf "Wonderful!", else "What a pity!".
 

Sample Input
5 3 5 4 6 6 0 0
 

Sample Output
What a pity! Wonderful! Wonderful!
 

Author
月野兔
 

Source
 

給出 n*m的方格 能往下往左或者左下三個方向走 從(n,m)開始

走到(1,1)的勝利 問誰能贏

#include<cstdio>
#include<cstring>
int main()
{
    int n,m;
    while(scanf("%d %d",&n,&m)!=EOF&&(n||m))
    {
        if(n%2&&m%2)
            printf("What a pity!\n");
        else
            printf("Wonderful!\n");
    }
    return 0;
}


發佈了94 篇原創文章 · 獲贊 4 · 訪問量 4萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章