hdu A + B Problem II

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 169696    Accepted Submission(s): 32544


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
2 1 2 112233445566778899 998877665544332211
 

Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 
Author
Ignatius.L
 

#include<stdio.h>
#include<string.h>
int main()
{
	char  str1[1000],str2[1000];
	int sum[1010],len1,len2,len;
	int i,k,n,c;
	scanf("%d",&n);
	for (c=1;c<=n;c++)
	{
		memset(sum,0,sizeof(sum));
		memset(str1,0,sizeof(str1));
		memset(str2,0,sizeof(str2));
		len1=len2=len=0;
		scanf("%s%s",str1,str2);
		len1=strlen(str1);
		len2=strlen(str2);
		for(i=0,k=len1-1;i<len1;i++,k--)
			sum[k]=str1[i]-'0';
		for(i=len2-1,k=0;i>=0;i--,k++)
			sum[k]+=str2[i]-'0';
		if(len1>=len2)  len=len1;
		else  len=len2;
		for(i=0;i<len;i++)
		{
			sum[i+1]+=sum[i]/10;
			sum[i]=sum[i]%10;
		}
		if(sum[len]>0)   len++;
		printf("Case %d:\n",c);
		printf("%s + %s = ",str1,str2);
		for (i=len-1;i>=0;i--)
			printf("%d",sum[i]);
		if(c<n)  printf("\n\n");
		else printf("\n");
		
	}
	return 0;
}



發佈了70 篇原創文章 · 獲贊 4 · 訪問量 4萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章