Integer Inquiry(UVA—424)

題目:

One of the first users of BIT’s new supercomputer was Chip Diller. He extended his exploration ofpowers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.“This supercomputer is great,” remarked Chip. “I only wish Timothy were here to see these results.”(Chip moved to a new apartment, once one became available on the third floor of the Lemon Skyapartments on Third Street.)
Input
The input will consist of at most 100 lines of text, each of which contains a single VeryLongInte-ger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (noVeryLongInteger will be negative).The final input line will contain a single zero on a line by itself.
Output
Your program should output the sum of the VeryLongIntegers given in the input.
Sample Input

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

<font color=red Sample Output

370370367037037036703703703670

解題思路:這個題是高精度的問題,多個大數相加的結果.

程序代碼:

#include<stdio.h>
#include<string.h>
int a[50000],b[50000],c[55000];
char s[200];
int main()
{
	int n,m,i,j,k;
	memset(a,0,sizeof(a));
	scanf("%s",s);
	m=strlen(s);
	j=0;
	for(i=m-1;i>=0;i--)
		a[j++]=s[i]-'0';
	while(scanf("%s",s)!=EOF)
	{
		memset(b,0,sizeof(b));
		memset(c,0,sizeof(c));
		if(s[0]=='0')
			break;
		n=strlen(s);
		j=0;
		for(i=n-1;i>=0;i--)
			b[j++]=s[i]-'0';
		if(n>m)
			k=n;
		else
			k=m;
		for(i=0;i<k;i++)
		{
			c[i]=a[i]+b[i]+c[i];
			if(c[i]>=10)
			{
				c[i+1]++;
				c[i]=c[i]%10;
			}
		}
		if(c[k]!=0)
			k++;
		for(i=0;i<k;i++)
			a[i]=c[i];
		m=k;	
	}
	for(i=m-1;i>=0;i--)
		printf("%d",a[i]);
	printf("\n");
	return 0;	
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章